summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
-rw-r--r--config.example5
-rw-r--r--mocp-scrobbler.install11
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c4935b05e52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mocp-scrobbler
+ pkgdesc = Last.fm scrobbler for MOC audio player
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/fluxid/mocp-scrobbler
+ install = mocp-scrobbler.install
+ arch = any
+ license = GPL
+ depends = python
+ depends = moc
+ source = https://raw.githubusercontent.com/fluxid/mocp-scrobbler/master/mocp-scrobbler.py
+ source = config.example
+ md5sums = f5aa370d01fcb088d123f1d6c522e7fe
+ md5sums = f8ac0e62a30c03bbf90761fc7d5ba624
+
+pkgname = mocp-scrobbler
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f2923146f05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=mocp-scrobbler
+pkgver=0.2
+pkgrel=1
+pkgdesc="Last.fm scrobbler for MOC audio player"
+arch=('any')
+url="https://github.com/fluxid/mocp-scrobbler"
+license=('GPL')
+depends=('python' 'moc')
+install=$pkgname.install
+source=('https://raw.githubusercontent.com/fluxid/mocp-scrobbler/master/mocp-scrobbler.py'
+ 'config.example')
+md5sums=('f5aa370d01fcb088d123f1d6c522e7fe'
+ 'f8ac0e62a30c03bbf90761fc7d5ba624')
+
+package() {
+ cd "$srcdir"
+
+ mkdir -p $pkgdir/usr/{bin,share/doc/$pkgname}
+ install -m755 $pkgname.py $pkgdir/usr/bin/
+ install -m644 config.example $pkgdir/usr/share/doc/$pkgname/
+}
diff --git a/config.example b/config.example
new file mode 100644
index 000000000000..7749ce9eaef3
--- /dev/null
+++ b/config.example
@@ -0,0 +1,5 @@
+[scrobbler]
+login = YOUR_LASTFM_LOGIN
+password = YOUR_PASSWORD
+streams = true
+hostname = post.audioscrobbler.com
diff --git a/mocp-scrobbler.install b/mocp-scrobbler.install
new file mode 100644
index 000000000000..bc2d136ebcad
--- /dev/null
+++ b/mocp-scrobbler.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo
+ echo " Copy the example file /usr/share/doc/mocp-scrobbler/config.example"
+ echo " to ~/.mocpscrob/config"
+ echo
+ echo " Replace login and password. The password variable will be replaced with"
+ echo " password_md5 on the first run. Its value will be the original value"
+ echo " hashed using MD5 algorithm. If you want to change password, just add"
+ echo " again password with you new password, password_md5 will be replaced."
+ echo
+}