summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD68
-rw-r--r--ttl-fixes.patch76
4 files changed, 173 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5aa0a2615e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = mod-mda-lv2-git
+ pkgdesc = MOD fork of the LV2 port of the MDA plugins (git version)
+ pkgver = 1.1.0.r217.b2df88c
+ pkgrel = 1
+ url = https://github.com/moddevices/mda-lv2
+ arch = x86_64
+ groups = lv2-plugins
+ groups = pro-audio
+ license = GPL-3.0-or-later
+ checkdepends = lv2lint
+ checkdepends = mod-lv2-extensions
+ makedepends = git
+ makedepends = lv2
+ makedepends = python2
+ depends = gcc-libs
+ depends = glibc
+ optdepends = lv2-host: to load the LV2 plugins
+ provides = mod-mda-lv2
+ conflicts = mod-mda-lv2
+ source = mod-mda-lv2::git+https://github.com/moddevices/mda-lv2.git
+ source = ttl-fixes.patch
+ sha256sums = SKIP
+ sha256sums = d65b3202225da4bb57611ec0f53b038386ae3f58d91fdbc7502c1ab032e62e80
+
+pkgname = mod-mda-lv2-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1ec3f8b904f1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+mod-mda-lv2/
+mod-mda-lv2-git-*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f489b9387a8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_pkgname=mod-mda-lv2
+pkgname=$_pkgname-git
+pkgver=1.1.0.r217.b2df88c
+pkgrel=1
+pkgdesc='MOD fork of the LV2 port of the MDA plugins (git version)'
+arch=(x86_64)
+url='https://github.com/moddevices/mda-lv2'
+license=(GPL-3.0-or-later)
+groups=(lv2-plugins pro-audio)
+depends=(gcc-libs glibc)
+makedepends=(git lv2 python2)
+checkdepends=(lv2lint mod-lv2-extensions)
+optdepends=('lv2-host: to load the LV2 plugins')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("$_pkgname::git+https://github.com/moddevices/mda-lv2.git"
+ 'ttl-fixes.patch')
+sha256sums=('SKIP'
+ 'd65b3202225da4bb57611ec0f53b038386ae3f58d91fdbc7502c1ab032e62e80')
+
+pkgver() {
+ cd $_pkgname
+ local ver=$(grep -E '^MDA_VERSION =' wscript | cut -d "'" -f 2)
+ printf "$ver.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_pkgname
+ patch -p1 -N -r - -i "$srcdir"/ttl-fixes.patch
+}
+
+build() {
+ cd $_pkgname
+ python2 waf configure --prefix=/usr
+ python2 waf -v
+}
+
+check() {
+ local _plugin
+ local _plugins=(Ambience Bandisto BeatBox Combo DX10 DeEss Degrade Delay Detune
+ Dither DubDelay Dynamics EPiano Image JX10 Leslie Limiter Loudness MultiBand
+ Overdrive Piano RePsycho RezFilter RingMod RoundPan Shepard Splitter Stereo
+ SubSynth TalkBox TestTone ThruZero Tracker Transient VocInput Vocoder)
+
+ cd $_pkgname
+ for _plugin in "${_plugins[@]}"; do
+ # NOTE: whitelist globally visible library: https://gitlab.com/drobilla/mda-lv2/-/issues/2
+ lv2lint -q -Mpack \
+ -s epianoData \
+ -s loudness \
+ -s lvz_new_audioeffectx \
+ -s lvz_translate_parameter \
+ -s pianoData \
+ -s '_Z*' \
+ -I "build/mod-mda-$_plugin.lv2" \
+ "http://moddevices.com/plugins/mda/$_plugin"
+ done
+}
+
+package() {
+ cd $_pkgname
+ python2 waf install --destdir "$pkgdir"
+ install -vDm 644 NEWS README -t "$pkgdir"/usr/share/doc/$pkgname
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ttl-fixes.patch b/ttl-fixes.patch
new file mode 100644
index 000000000000..29eff93c1f75
--- /dev/null
+++ b/ttl-fixes.patch
@@ -0,0 +1,76 @@
+diff --git a/bundles/mod-mda-Combo.lv2/Combo.ttl b/bundles/mod-mda-Combo.lv2/Combo.ttl
+index f932a9f..1eb96e4 100644
+--- a/bundles/mod-mda-Combo.lv2/Combo.ttl
++++ b/bundles/mod-mda-Combo.lv2/Combo.ttl
+@@ -68,6 +68,7 @@ mda:Combo
+ lv2:minimum -100 ;
+ lv2:maximum 100 ;
+ units:unit [
++ a units:Unit ;
+ rdfs:label "Soft/Hard" ;
+ units:symbol "S <> H" ;
+ units:render "%f Sh"
+diff --git a/bundles/mod-mda-DX10.lv2/DX10.ttl b/bundles/mod-mda-DX10.lv2/DX10.ttl
+index 8c4f3ee..40d6520 100644
+--- a/bundles/mod-mda-DX10.lv2/DX10.ttl
++++ b/bundles/mod-mda-DX10.lv2/DX10.ttl
+@@ -100,6 +100,7 @@ N.B. The carrier operator has a fixed coarse tuning ratio of 2.
+ lv2:minimum 0.0 ;
+ lv2:maximum 40.0 ;
+ units:unit [
++ a units:Unit ;
+ rdfs:label "ratio" ;
+ units:symbol "ratio" ;
+ units:render "%f" ;
+@@ -115,6 +116,7 @@ N.B. The carrier operator has a fixed coarse tuning ratio of 2.
+ lv2:minimum 0.001 ;
+ lv2:maximum 0.750 ;
+ units:unit [
++ a units:Unit ;
+ rdfs:label "ratio" ;
+ units:symbol "ratio" ;
+ units:render "%f" ;
+diff --git a/bundles/mod-mda-Degrade.lv2/Degrade.ttl b/bundles/mod-mda-Degrade.lv2/Degrade.ttl
+index 8c69ce9..38caf64 100644
+--- a/bundles/mod-mda-Degrade.lv2/Degrade.ttl
++++ b/bundles/mod-mda-Degrade.lv2/Degrade.ttl
+@@ -68,6 +68,7 @@ Modeled by MDA
+ lv2:minimum 4 ;
+ lv2:maximum 16 ;
+ units:unit [
++ a units:Unit ;
+ rdfs:label "bits" ;
+ units:symbol "bit" ;
+ units:render "%f bits"
+@@ -85,6 +86,7 @@ Modeled by MDA
+ lv2:minimum 4800 ;
+ lv2:maximum 48000 ;
+ units:unit [
++ a units:Unit ;
+ rdfs:label "ssh" ;
+ units:symbol "s_sh" ;
+ units:render "%f Hz"
+@@ -130,8 +132,9 @@ Modeled by MDA
+ lv2:minimum 0.0 ;
+ lv2:maximum 1.0 ;
+ units:unit [
+- rdfs:label "nonlin" ;
+- units:symbol "nonlin" ;
++ a units:Unit ;
++ rdfs:label "nonlin" ;
++ units:symbol "nonlin" ;
+ ] ;
+ rdfs:comment """Additional harmonic distortion "thickening" (turn control to left or right for different sound characters)"""
+ ] , [
+diff --git a/bundles/mod-mda-Dynamics.lv2/Dynamics.ttl b/bundles/mod-mda-Dynamics.lv2/Dynamics.ttl
+index 8671eb5..ac19b0b 100644
+--- a/bundles/mod-mda-Dynamics.lv2/Dynamics.ttl
++++ b/bundles/mod-mda-Dynamics.lv2/Dynamics.ttl
+@@ -45,6 +45,7 @@ mda:Dynamics
+ lv2:minimum -17.0 ;
+ lv2:maximum 0.5 ;
+ units:unit [
++ a units:Unit ;
+ rdfs:label "ratio" ;
+ units:symbol ":1" ;
+ units:render "%f" ;