summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1854db1e5b21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mod_authn_otp
+ pkgdesc = Apache module for one time password authentication
+ pkgver = 1.1.7
+ pkgrel = 1
+ url = http://code.google.com/p/mod-authn-otp/
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = apache
+ depends = openssl
+ source = https://s3.amazonaws.com/archie-public/mod-authn-otp/mod_authn_otp-1.1.7.tar.gz
+ md5sums = 0f21b3a3a52da371151d92ae51dfb750
+
+pkgname = mod_authn_otp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76f1d4520388
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Christoph Bayer <chrbayer@criby.de>
+
+pkgname=mod_authn_otp
+pkgver=1.1.7
+pkgrel=1
+pkgdesc='Apache module for one time password authentication'
+arch=('i686' 'x86_64')
+url='http://code.google.com/p/mod-authn-otp/'
+license=('Apache')
+depends=('openssl')
+makedepends=('apache')
+source=("https://s3.amazonaws.com/archie-public/mod-authn-otp/${pkgname}-${pkgver}.tar.gz")
+md5sums=('0f21b3a3a52da371151d92ae51dfb750')
+
+build() {
+ cd $srcdir/${pkgname}-${pkgver}
+ ./configure
+ make || return 1
+ mkdir -p "${pkgdir}/usr/lib/httpd/modules/"
+ make DESTDIR="${pkgdir}" install
+}