summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD23
-rw-r--r--perl-5-33-7.patch11
3 files changed, 26 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b08adc05ac88..c3083450152d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,23 @@
pkgbase = mod_perl
- pkgdesc = Apache module that embeds the Perl interpreter within the server
- pkgver = 2.0.11
- pkgrel = 5
- url = http://perl.apache.org/
- arch = i686
- arch = x86_64
- arch = armv6h
- arch = armv7h
- license = APACHE
- depends = perl
- depends = apache
- depends = db
- depends = apr-util
- depends = perl-linux-pid
- options = !emptydirs
- source = http://apache.org/dist/perl/mod_perl-2.0.11.tar.gz
- source = http://apache.org/dist/perl/mod_perl-2.0.11.tar.gz.asc
- source = perl-5-33-7.patch
- validpgpkeys = 2026E6A4A6A4483E61BA6F3FAB34BA0040E92ECE
- sha256sums = ca2a9e18cdf90f9c6023e786369d5ba75e8dac292ebfea9900c29bf42dc16f74
- sha256sums = SKIP
- sha256sums = 9df55e5c5d55771687019645c651204fb62cabe24b904a31197a78cdf9332a21
-
-pkgname = mod_perl
+ pkgdesc = Apache module that embeds the Perl interpreter within the server
+ pkgver = 2.0.12
+ pkgrel = 1
+ url = http://perl.apache.org/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = APACHE
+ depends = perl
+ depends = apache
+ depends = db
+ depends = apr-util
+ depends = perl-linux-pid
+ options = !emptydirs
+ source = http://apache.org/dist/perl/mod_perl-2.0.12.tar.gz
+ source = http://apache.org/dist/perl/mod_perl-2.0.12.tar.gz.asc
+ validpgpkeys = 2026E6A4A6A4483E61BA6F3FAB34BA0040E92ECE
+ sha256sums = f5b821b59b0fdc9670e46ed0fcf32d8911f25126189a8b68c1652f9221eee269
+ sha256sums = SKIP
+pkgname = mod_perl \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 1a794c0845b2..cdccb0ba3adf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,31 +5,18 @@
# Contributor: Tom K <tomk@runbox.com>
pkgname=mod_perl
-pkgver=2.0.11
-pkgrel=5
+pkgver=2.0.12
+pkgrel=1
pkgdesc='Apache module that embeds the Perl interpreter within the server'
arch=(i686 x86_64 armv6h armv7h)
url='http://perl.apache.org/'
license=(APACHE)
depends=(perl apache db apr-util perl-linux-pid)
options=(!emptydirs)
-source=(http://apache.org/dist/perl/mod_perl-$pkgver.tar.gz{,.asc} perl-5-33-7.patch)
+source=(http://apache.org/dist/perl/mod_perl-$pkgver.tar.gz{,.asc})
validpgpkeys=(2026E6A4A6A4483E61BA6F3FAB34BA0040E92ECE)
-sha256sums=('ca2a9e18cdf90f9c6023e786369d5ba75e8dac292ebfea9900c29bf42dc16f74'
- 'SKIP'
- '9df55e5c5d55771687019645c651204fb62cabe24b904a31197a78cdf9332a21')
-
-prepare() {
- cd mod_perl-$pkgver
- # Workaround to support Perl 5.33.7++ - should be fixed upstream soon
- # See https://github.com/Perl/perl5/issues/18617
- patch --forward --strip=0 --input="${srcdir}/perl-5-33-7.patch"
-
- # Workaround per http://mail-archives.apache.org/mod_mbox/perl-modperl/202009.mbox/%3C8d69b2e8-4a4e-bde4-6eff-7018ddf6354e%40gmail.com%3E
- sed -i -e '1098,1102d' Apache-Test/lib/Apache/TestRun.pm
- sed -i '51,56c push @INC, "xs/tables/current24";' lib/ModPerl/MapUtil.pm
- sed -i -e '66d' src/modules/perl/modperl_sys.c
-}
+sha256sums=('f5b821b59b0fdc9670e46ed0fcf32d8911f25126189a8b68c1652f9221eee269'
+ 'SKIP')
build() {
cd mod_perl-$pkgver
diff --git a/perl-5-33-7.patch b/perl-5-33-7.patch
deleted file mode 100644
index f0c588061775..000000000000
--- a/perl-5-33-7.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/modules/perl/modperl_perl.c 2021/04/20 13:48:02 1889013
-+++ src/modules/perl/modperl_perl.c 2021/04/20 13:55:29 1889014
-@@ -268,7 +268,7 @@
- #ifdef MP_NEED_HASH_SEED_FIXUP
- if (MP_init_hash_seed_set) {
- #if MP_PERL_VERSION_AT_LEAST(5, 17, 6)
-- memcpy(&PL_hash_seed, &MP_init_hash_seed,
-+ memcpy(PL_hash_seed, &MP_init_hash_seed,
- sizeof(PL_hash_seed) > sizeof(MP_init_hash_seed) ?
- sizeof(MP_init_hash_seed) : sizeof(PL_hash_seed));
- PL_hash_seed_set = MP_init_hash_seed_set;