summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rw-r--r--apache24.patch49
3 files changed, 18 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d7583e9cc46..07aff09cb7ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,12 @@
-# Generated by mksrcinfo v8
-# Thu Sep 8 21:39:32 UTC 2016
pkgbase = mod_scgi
- pkgdesc = Apache module that implements SCGI protocol
- pkgver = 1.15
+ pkgdesc = A Simple Common Gateway Interface alternative
+ pkgver = 2.2
pkgrel = 1
url = http://python.ca/scgi/
- arch = i686
arch = x86_64
- arch = armv5h
- arch = armv6h
- arch = armv7h
license = custom
makedepends = apache
- source = http://python.ca/scgi/releases/scgi-1.15.tar.gz
- source = apache24.patch
- sha256sums = e6cd197b089cca6478e9995ed076975756c30ebb903aabce912f404ee75a6d6f
- sha256sums = ce3a01152543d0d7f9f63528aad89b61ef8ce1b429d24fd1aca323fc2713ee65
+ source = http://python.ca/scgi/releases/scgi-2.2.tar.gz
+ sha512sums = 5af72e45cea7a088f258273b5c7f6c820376d331f1223b52b5a0542aefbbd4523f98e07cf72531b5d08b1813f44181eef7a3ac8b0fa60785b995488635c871a4
pkgname = mod_scgi
-
diff --git a/PKGBUILD b/PKGBUILD
index 3fdc225eae7c..bd157a721937 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,38 +2,35 @@
# Contributor: Roman Cheplyaka <roma@ro-che.info>
pkgname=mod_scgi
-pkgver=1.15
+pkgver=2.2
pkgrel=1
-pkgdesc="Apache module that implements SCGI protocol"
+pkgdesc="A Simple Common Gateway Interface alternative"
url="http://python.ca/scgi/"
makedepends=('apache')
license=('custom')
-arch=('i686' 'x86_64' 'armv5h' 'armv6h' 'armv7h')
-source=(http://python.ca/scgi/releases/scgi-$pkgver.tar.gz apache24.patch)
-#source=(http://python.ca/scgi/releases/scgi-$pkgver.tar.gz)
-#md5sums=('73d942a9ecdf4f20c8234e72ea82c7ee' 'bf3d7766a3ac7e2bd44ebfa1e858f4d5')
-sha256sums=('e6cd197b089cca6478e9995ed076975756c30ebb903aabce912f404ee75a6d6f'
- 'ce3a01152543d0d7f9f63528aad89b61ef8ce1b429d24fd1aca323fc2713ee65')
+arch=('x86_64')
+source=(http://python.ca/scgi/releases/scgi-$pkgver.tar.gz)
+sha512sums=('5af72e45cea7a088f258273b5c7f6c820376d331f1223b52b5a0542aefbbd4523f98e07cf72531b5d08b1813f44181eef7a3ac8b0fa60785b995488635c871a4')
prepare() {
- cd $srcdir/scgi-$pkgver/apache2
- patch -p2 -i $srcdir/apache24.patch
+ cd "${srcdir}/scgi-$pkgver/apache2"
sed -i 's/apxs2/apxs/g' Makefile || return 1
+ sed -i 's/apache2ctl/apachectl/g' Makefile || return 1
}
build() {
- cd $srcdir/scgi-$pkgver/apache2
+ cd "${srcdir}/scgi-${pkgver}/apache2"
make || return 1
}
package() {
install -m 644 -D \
- $srcdir/scgi-$pkgver/apache2/.libs/mod_scgi.so \
- $pkgdir/usr/lib/httpd/modules/mod_scgi.so || return 1
+ "${srcdir}/scgi-${pkgver}/apache2/.libs/mod_scgi.so" \
+ "${pkgdir}/usr/lib/httpd/modules/mod_scgi.so" || return 1
install -m 644 -D \
- $srcdir/scgi-$pkgver/LICENSE.txt \
- $pkgdir/usr/share/licenses/${pkgname}/LICENSE.txt || return 1
+ "${srcdir}/scgi-${pkgver}/LICENSE.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt" || return 1
install -m 644 -D \
- $srcdir/scgi-$pkgver/doc/LICENSE_110.txt \
- $pkgdir/usr/share/licenses/${pkgname}/LICENSE_110.txt || return 1
+ "${srcdir}/scgi-${pkgver}/doc/LICENSE_110.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE_110.txt" || return 1
}
diff --git a/apache24.patch b/apache24.patch
deleted file mode 100644
index 8c1240b18c31..000000000000
--- a/apache24.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- a/apache2/mod_scgi.c
-+++ b/apache2/mod_scgi.c
-@@ -135,16 +135,16 @@
- return DECLINED;
- }
-
--static void log_err(const char *file, int line, request_rec *r,
-+static void log_err(const char *file, int line, int index, request_rec *r,
- apr_status_t status, const char *msg)
- {
-- ap_log_rerror(file, line, APLOG_ERR, status, r, "scgi: %s", msg);
-+ ap_log_rerror(file, line, index, APLOG_ERR, status, r, "scgi: %s", msg);
- }
-
--static void log_debug(const char *file, int line, request_rec *r, const
-+static void log_debug(const char *file, int line, int index, request_rec *r, const
- char *msg)
- {
-- ap_log_rerror(file, line, APLOG_DEBUG, APR_SUCCESS, r, msg);
-+ ap_log_rerror(file, line, index, APLOG_DEBUG, APR_SUCCESS, r, "%s", msg);
- }
-
- static char *http2env(apr_pool_t *p, const char *name)
-@@ -312,7 +312,7 @@
- int i;
- apr_status_t rv = 0;
- apr_port_t port = 0;
-- GET_PORT(port, r->connection->remote_addr);
-+ GET_PORT(port, r->useragent_addr);
-
- log_debug(APLOG_MARK,r, "sending headers");
- t = apr_table_make(r->pool, 40);
-@@ -324,14 +324,14 @@
- buf = "0";
- add_header(t, "CONTENT_LENGTH", buf);
- add_header(t, "SCGI", SCGI_PROTOCOL_VERSION);
-- add_header(t, "SERVER_SOFTWARE", ap_get_server_version());
-+ add_header(t, "SERVER_SOFTWARE", ap_get_server_banner());
- add_header(t, "SERVER_PROTOCOL", r->protocol);
- add_header(t, "SERVER_NAME", ap_get_server_name(r));
- add_header(t, "SERVER_ADMIN", r->server->server_admin);
- add_header(t, "SERVER_ADDR", r->connection->local_ip);
- add_header(t, "SERVER_PORT", apr_psprintf(r->pool, "%u",
- ap_get_server_port(r)));
-- add_header(t, "REMOTE_ADDR", r->connection->remote_ip);
-+ add_header(t, "REMOTE_ADDR", r->useragent_ip);
- add_header(t, "REMOTE_PORT", apr_psprintf(r->pool, "%d", port));
- add_header(t, "REMOTE_USER", r->user);
- add_header(t, "REQUEST_METHOD", r->method);