summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--readme.install42
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa5fdde9f5e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = modprobed-db
+ pkgdesc = Keeps track of EVERY kernel module ever used - useful for those of us who make localmodconfig :)
+ pkgver = 2.29
+ pkgrel = 1
+ url = https://wiki.archlinux.org/index.php/Modprobed-db
+ install = readme.install
+ arch = any
+ license = MIT
+ depends = kmod
+ optdepends = sudo
+ conflicts = modprobed_db
+ replaces = modprobed_db
+ source = http://repo-ck.com/source/modprobed-db/modprobed-db-2.29.tar.xz
+ sha256sums = 707afa063fd78c60a0585906294493e8658054dbcd933d175be78b2945cc1354
+
+pkgname = modprobed-db
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70cc871dbb45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: graysky <graysky AT archlinux dot us>
+pkgname=modprobed-db
+pkgver=2.29
+pkgrel=1
+pkgdesc='Keeps track of EVERY kernel module ever used - useful for those of us who make localmodconfig :)'
+arch=('any')
+license=('MIT')
+depends=('kmod')
+optdepends=('sudo')
+replaces=('modprobed_db')
+conflicts=('modprobed_db')
+url="https://wiki.archlinux.org/index.php/Modprobed-db"
+source=("http://repo-ck.com/source/$pkgname/$pkgname-$pkgver.tar.xz")
+sha256sums=('707afa063fd78c60a0585906294493e8658054dbcd933d175be78b2945cc1354')
+install=readme.install
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/readme.install b/readme.install
new file mode 100644
index 000000000000..3842eeec2162
--- /dev/null
+++ b/readme.install
@@ -0,0 +1,42 @@
+post_install() {
+ echo '--------------------------------------------------------------------------'
+ echo ' See the manpage for usage and setup: man modprobed-db'
+ echo '--------------------------------------------------------------------------'
+}
+
+post_remove() {
+ echo '-----------------------------------------------------------------------'
+ echo ' Remember to remove the entry in your crontab if you made one!'
+ echo '-----------------------------------------------------------------------'
+}
+
+# $1: The new package version
+# $2: The old package version
+
+post_upgrade() {
+ if [ $(vercmp $2 1.8) -lt 0 ]; then
+ echo '----------------------------------------------------------------------'
+ echo ' WARNING:'
+ echo
+ echo 'You MUST modify ANY and ALL calls to /usr/bin/modprobed-db to'
+ echo 'include the "store" switch.'
+ echo 'For example, in the root user crontab, /etc/rc.local.shutdown, etc.'
+ echo
+ echo 'In other words: --> /usr/bin/modprobed-db store <--'
+ echo
+ echo 'The default action in version 2.0 is to display the help file!'
+ echo 'Inaction on your part here will cause NO action to be taken by'
+ echo 'the software!'
+ echo
+ echo 'You have been warned!'
+ echo '----------------------------------------------------------------------'
+ fi
+
+ if [ $(vercmp $2 2.23) -lt 0 ]; then
+ echo '--> A minor name change has occurred which requires your attention.'
+ echo '--> Underscores have been replaced with hyphens:'
+ echo '--> modprobed_db --> modprobed-db'
+ echo '-->'
+ echo '--> Make sure you update your crontab accordingly.'
+ fi
+}