summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 030162fcc04c..5cad0492f48a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = modrinth-app-git
pkgdesc = Official Modrinth launcher. Open-source, built by the community, for the community.
- pkgver = r147.3f46882
+ pkgver = r241.7394fdc
pkgrel = 1
url = https://github.com/modrinth/theseus
arch = x86_64
license = GPL3
makedepends = cargo-tauri
- makedepends = yarn
makedepends = pnpm
makedepends = git
depends = webkit2gtk
provides = modrinth-app
conflicts = modrinth-app
options = !lto
+ options = !debug
source = git+https://github.com/modrinth/theseus
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2df6c1661ccc..9ad320f8d9a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=modrinth-app-git
_gitname=theseus
-pkgver=r178.6d9d403
+pkgver=r241.7394fdc
pkgrel=1
pkgdesc='Official Modrinth launcher. Open-source, built by the community, for the community.'
url=https://github.com/modrinth/theseus
@@ -11,8 +11,8 @@ license=(GPL3)
conflicts=('modrinth-app')
provides=('modrinth-app')
depends=('webkit2gtk')
-makedepends=('cargo-tauri' 'yarn' 'pnpm' 'git')
-options=(!lto) # Enable devtools (thanks @FabioLolix)
+makedepends=('cargo-tauri' 'pnpm' 'git')
+options=(!lto !debug) # !lto = Enable devtools (thanks @FabioLolix)
source=("git+https://github.com/modrinth/theseus")
sha256sums=('SKIP')
@@ -31,7 +31,12 @@ build() {
"s|\"targets\": \"all\"|\"targets\": \"deb\"|" \
"src-tauri/tauri.conf.json"
- yarn install
+ # Allow using other pnpm versions as this doesn't seem to cause errors
+ # & doesn't require to install another pnpm version for no reason
+ # (excepted = 8.6.0, current = 9.1.4)
+ export COREPACK_ENABLE_STRICT=0
+ pnpm install
+
cargo tauri build
}