summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD44
-rw-r--r--moksha.install12
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..499407f97c08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Mon Jan 18 19:06:12 UTC 2016
+pkgbase = moksha
+ pkgdesc = A fork of the E17 window manager
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://mokshadesktop.org
+ install = moksha.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = desktop-file-utils
+ depends = e_dbus
+ depends = elementary
+ optdepends = acpid: power events on laptop lid close
+ optdepends = bc: calculator in everything module
+ optdepends = bluez4: bluetooth module
+ optdepends = connman: network module
+ optdepends = doxygen: build documentation
+ optdepends = evas_generic_loaders: provide support for SVG icons
+ optdepends = gdb: create backtraces on crash
+ optdepends = geoclue2: geolocation module
+ provides = notification-daemon
+ conflicts = enlightenment
+ backup = etc/enlightenment/sysactions.conf
+ backup = etc/xdg/menus/e-applications.menu
+ source = https://github.com/JeffHoogland/moksha/archive/0.2.0.tar.gz
+ sha256sums = f03601558902b9f9b286d85aa5da418dfa74acf3e3947992dcb131cc0e44994e
+
+pkgname = moksha
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94f128e6841c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
+
+pkgname=moksha
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A fork of the E17 window manager"
+arch=('i686' 'x86_64')
+url="http://mokshadesktop.org"
+license=('BSD')
+depends=('desktop-file-utils' 'e_dbus' 'elementary')
+optdepends=('acpid: power events on laptop lid close'
+ 'bc: calculator in everything module'
+ 'bluez4: bluetooth module'
+ 'connman: network module'
+ 'doxygen: build documentation'
+ 'evas_generic_loaders: provide support for SVG icons'
+ 'gdb: create backtraces on crash'
+ 'geoclue2: geolocation module')
+provides=('notification-daemon')
+conflicts=("enlightenment")
+backup=('etc/enlightenment/sysactions.conf'
+ 'etc/xdg/menus/e-applications.menu')
+source=("https://github.com/JeffHoogland/moksha/archive/$pkgver.tar.gz")
+sha256sums=('f03601558902b9f9b286d85aa5da418dfa74acf3e3947992dcb131cc0e44994e')
+install=('moksha.install')
+
+build() {
+ cd $pkgname-$pkgver
+
+ export CFLAGS="$CFLAGS -fvisibility=hidden"
+
+ ./autogen.sh \
+ --prefix=/usr \
+ --sysconfdir=/etc
+
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/moksha.install b/moksha.install
new file mode 100644
index 000000000000..1182e768fc75
--- /dev/null
+++ b/moksha.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-mime-database usr/share/mime > /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}