summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abf77b08fe64..c7094cce7784 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = molequeue-git
pkgdesc = Desktop integration of high performance computing resources
pkgver = 0.9.0.r817.0511c9a
- pkgrel = 1
+ pkgrel = 2
url = http://www.openchemistry.org/projects/molequeue
arch = x86_64
license = Kitware
@@ -10,8 +10,7 @@ pkgbase = molequeue-git
depends = qt5-base
provides = molequeue
conflicts = molequeue
- source = git://github.com/OpenChemistry/molequeue.git
+ source = git+https://github.com/OpenChemistry/molequeue.git
sha256sums = SKIP
pkgname = molequeue-git
-
diff --git a/.gitignore b/.gitignore
index 1b71d10134ff..0736899ebad6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,6 +3,7 @@ pkg/
src/
*.log
*.xz
+*.zst
# source files
molequeue/
diff --git a/PKGBUILD b/PKGBUILD
index 2b6b7d2d92c6..c9237406df2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=molequeue
pkgname="${_pkgname}-git"
pkgver=0.9.0.r817.0511c9a
-pkgrel=1
+pkgrel=2
pkgdesc="Desktop integration of high performance computing resources"
url="http://www.openchemistry.org/projects/molequeue"
arch=("x86_64")
@@ -12,7 +12,7 @@ depends=("qt5-base")
makedepends=("git" "cmake")
conflicts=("${_pkgname}")
provides=("${_pkgname}")
-source=("git://github.com/OpenChemistry/${_pkgname}.git")
+source=("git+https://github.com/OpenChemistry/${_pkgname}.git")
sha256sums=("SKIP")
pkgver() {
@@ -24,24 +24,26 @@ pkgver() {
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}"
cmake \
-DCMAKE_BUILD_TYPE:STRING=Release \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DCMAKE_INSTALL_LIBDIR:PATH=lib \
-DENABLE_TESTING:BOOL=ON \
-DBUILD_SHARED_LIBS:BOOL=ON \
- .
+ -Bbuild \
+ "${srcdir}/${_pkgname}"
+ cd build
make
}
check() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/build"
make test
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/build"
make DESTDIR="${pkgdir}" install
- install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -D -m 644 "${srcdir}/${_pkgname}"/LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}