summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rwxr-xr-xmolprobity.sh1
3 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 257da2c074c6..0f13b7b33879 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = molprobity-git
pkgdesc = All-atom structure validation for macromolecular crystallography
pkgver = r1013.ee5bdd4
- pkgrel = 1
+ pkgrel = 2
url = http://molprobity.biochem.duke.edu/
arch = any
license = BSD
@@ -25,6 +25,8 @@ pkgbase = molprobity-git
conflicts = molprobity-git
options = !strip
source = molprobity-git::git+https://github.com/rlabduke/MolProbity#branch=molprobity_4.2
+ source = molprobity.sh
+ md5sums = SKIP
md5sums = SKIP
pkgname = molprobity-git
diff --git a/PKGBUILD b/PKGBUILD
index d6e164cf8825..2ddcda9ca150 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Joshua Hardy joshinsilico
pkgname=molprobity-git
pkgver=r1013.ee5bdd4
-pkgrel=1
+pkgrel=2
pkgdesc="All-atom structure validation for macromolecular crystallography"
arch=('any')
url="http://molprobity.biochem.duke.edu/"
@@ -11,8 +11,9 @@ makedepends=('python2' 'git' 'subversion' 'curl' 'tar' 'make' 'gawk')
provides=("${pkgname%-VCS}")
conflicts=("${pkgname%-VCS}")
options=('!strip')
-source=('molprobity-git::git+https://github.com/rlabduke/MolProbity#branch=molprobity_4.2')
-md5sums=('SKIP')
+source=('molprobity-git::git+https://github.com/rlabduke/MolProbity#branch=molprobity_4.2'
+'molprobity.sh')
+md5sums=('SKIP' 'SKIP')
pkgver() {
cd "$srcdir/${pkgname%-VCS}"
@@ -32,7 +33,8 @@ build() {
package() {
cd "$srcdir/${pkgname%-VCS}"
- install -d "${pkgdir}"/opt/MolProbity "${pkgdir}"/usr/share/licenses/molprobity-git
+ install -d "${pkgdir}"/opt/MolProbity "${pkgdir}"/usr/share/licenses/molprobity-git $pkgdir/etc/profile.d/
cp -r * "${pkgdir}"/opt/MolProbity/.
cp LICENSE.html "${pkgdir}"/usr/share/licenses/molprobity-git/.
+ cp $srcdir/molprobity.sh $pkgdir/etc/profile.d/.
}
diff --git a/molprobity.sh b/molprobity.sh
new file mode 100755
index 000000000000..d2a36f0a73b8
--- /dev/null
+++ b/molprobity.sh
@@ -0,0 +1 @@
+PATH=$PATH:/opt/MolProbity/cmdline