summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1642ac854dc7..e098bc854991 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mongodb-shell
pkgdesc = The MongoDB Shell includes all features of legacy mongo shell with new syntax highligting, clear error messages and intelligent autocomplete.
- pkgver = 0.7.7
+ pkgver = 0.9.0
pkgrel = 1
url = https://www.mongodb.com/
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = mongodb-shell
optdepends = mongodb-bin
provides = mongosh
options = !strip
- source = https://downloads.mongodb.com/compass/mongosh-0.7.7-linux.tgz
- sha256sums = 7b246dc1590a7e63680a135f895c1356896fea6e9a2aa37b89ffa11497882367
+ source = https://downloads.mongodb.com/compass/mongosh-0.9.0-linux.tgz
+ sha256sums = 79db7889335a753da094159764ceb405b7708745ddc7f7a74f24b04438101ddc
pkgname = mongodb-shell
diff --git a/PKGBUILD b/PKGBUILD
index 69d3b5aa8538..c62f343402de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aman Sinha
pkgname=mongodb-shell
-pkgver=0.7.7
+pkgver=0.9.0
pkgrel=1
pkgdesc='The MongoDB Shell includes all features of legacy mongo shell with new syntax highligting, clear error messages and intelligent autocomplete.'
url='https://www.mongodb.com/'
@@ -10,11 +10,14 @@ optdepends=('mongodb-bin')
provides=("mongosh")
arch=('x86_64')
source=("https://downloads.mongodb.com/compass/mongosh-$pkgver-linux.tgz")
-sha256sums=("7b246dc1590a7e63680a135f895c1356896fea6e9a2aa37b89ffa11497882367")
+sha256sums=("79db7889335a753da094159764ceb405b7708745ddc7f7a74f24b04438101ddc")
options=(!strip)
package() {
cd $srcdir
install -Dm755 ./bin/mongosh $pkgdir/usr/bin/mongosh
+ install -Dm755 ./bin/mongocryptd-mongosh $pkgdir/usr/bin/mongocryptd-mongosh
install -Dm644 ./LICENSE-mongosh $pkgdir/usr/share/doc/$pkgname/LICENSE
install -Dm644 ./THIRD_PARTY_NOTICES $pkgdir/usr/share/doc/$pkgname/THIRD_PARTY_NOTICES
+ install -Dm644 ./LICENSE-mongocryptd $pkgdir/usr/share/doc/$pkgname/LICENSE-mongocryptd
+ install -Dm644 ./README $pkgdir/usr/share/doc/$pkgname/README
}