summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
-rw-r--r--check_kdc.patch4
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0e9a603f9ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = monitoring-plugins-kdc
+ pkgdesc = Monitoring plugin for Nagios, Icinga etc. for KDCs
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://exchange.nagios.org/directory/Plugins/Security/check_kdc/details
+ arch = any
+ license = GPL
+ license = Perl-Artistic
+ depends = perl
+ depends = monitoring-plugins
+ source = https://exchange.nagios.org/components/com_mtree/attachment.php?link_id=1287&cf_id=24
+ source = check_kdc.patch
+ md5sums = 2b86dee78f2f24540edbe846b6504043
+ md5sums = 9666e179db04e81904b80bea39cb1980
+
+pkgname = monitoring-plugins-kdc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f3f1dbee08b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: AndrĂ¡s Wacha <awacha aT gMaIl>
+pkgname=monitoring-plugins-kdc
+pkgver=1.0
+pkgrel=1
+pkgdesc="Monitoring plugin for Nagios, Icinga etc. for KDCs"
+arch=('any')
+url="https://exchange.nagios.org/directory/Plugins/Security/check_kdc/details"
+license=('GPL' 'Perl-Artistic')
+depends=('perl' 'monitoring-plugins')
+makedepends=()
+checkdepends=()
+source=("https://exchange.nagios.org/components/com_mtree/attachment.php?link_id=1287&cf_id=24"
+ "check_kdc.patch")
+md5sums=('2b86dee78f2f24540edbe846b6504043'
+ '9666e179db04e81904b80bea39cb1980')
+
+
+prepare() {
+ cp attachment.php\?link_id\=1287\&cf_id\=24 check_kdc
+ patch check_kdc < check_kdc.patch
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/lib/monitoring-plugins/
+ cp check_kdc ${pkgdir}/usr/lib/monitoring-plugins/check_kdc
+ chmod +x ${pkgdir}/usr/lib/monitoring-plugins/check_kdc
+}
diff --git a/check_kdc.patch b/check_kdc.patch
new file mode 100644
index 000000000000..a31bad875361
--- /dev/null
+++ b/check_kdc.patch
@@ -0,0 +1,4 @@
+92c92
+< err=`KRB5_CONFIG=$conf /usr/kerberos/bin/kinit -c "$cc" -k -t "$keytab" "$principal" 2>&1`
+---
+> err=`KRB5_CONFIG=$conf /usr/bin/kinit -c "$cc" -k -t "$keytab" "$principal" 2>&1`