summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD53
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d4b232c09ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Apr 27 12:28:08 UTC 2017
+pkgbase = monkeyjump
+ pkgdesc = Minimalistic GUI for playing Go with GnuGo and other GTP applications
+ pkgver = 0.5
+ pkgrel = 1
+ url = http://github.com/xyproto/monkeyjump
+ arch = any
+ license = GPL2
+ makedepends = setconf
+ makedepends = python2-setuptools
+ depends = python2-pygame
+ depends = gnugo
+ backup = etc/monkeyjump/gnugocmd.conf
+ backup = etc/monkeyjump/theme.conf
+ backup = etc/monkeyjump/keybindings.conf
+ source = monkeyjump::git://github.com/xyproto/monkeyjump.git#commit=a6fcea4e0f03c09a47b0117567893d0fe882b2a8
+ md5sums = SKIP
+
+pkgname = monkeyjump
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b565c3d9ac5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+
+pkgname=monkeyjump
+pkgver=0.5
+pkgrel=1
+pkgdesc='Minimalistic GUI for playing Go with GnuGo and other GTP applications'
+arch=('any')
+url='http://github.com/xyproto/monkeyjump'
+license=('GPL2')
+depends=('python2-pygame' 'gnugo')
+makedepends=('setconf' 'python2-setuptools')
+backup=('etc/monkeyjump/gnugocmd.conf' 'etc/monkeyjump/theme.conf' 'etc/monkeyjump/keybindings.conf')
+source=('monkeyjump::git://github.com/xyproto/monkeyjump.git#commit=a6fcea4e0f03c09a47b0117567893d0fe882b2a8')
+md5sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+
+ gendesk -f -n \
+ --pkgname="$pkgname" \
+ --pkgdesc="$pkgdesc" \
+ --exec="/usr/bin/monkeyjump 19" \
+ --categories="Game;BoardGame;" \
+ --terminal=true
+
+ setconf monkeyjump CONFDIR \"/etc/monkeyjump\"
+ setconf monkeyjump THEMEDIR \"/usr/share/monkeyjump/themes\"
+}
+
+package() {
+ cd "$pkgname"
+
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ # Executable
+ install -Dm755 monkeyjump "$pkgdir/usr/bin/monkeyjump"
+
+ # Themes
+ install -d "$pkgdir/usr/share/monkeyjump/themes"
+ cp -r themes/* "$pkgdir/usr/share/monkeyjump/themes/"
+
+ # Configuration
+ install -d "$pkgdir/etc/monkeyjump"
+ install -Dm644 conf/* "$pkgdir/etc/monkeyjump/"
+
+ # Desktop shortcut and icon
+ install -Dm644 "$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "dotimages/$pkgname.png" \
+ "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}
+
+# vim:set ts=2 sw=2 et: