summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a6752c3405a..0dfbbde847e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = monolith
pkgdesc = CLI to save web pages as single HTML files
- pkgver = 2.0.16
- pkgrel = 2
+ pkgver = 2.0.23
+ pkgrel = 1
url = https://github.com/Y2Z/monolith
- arch = i686
arch = x86_64
- license = custom
+ arch = aarch64
+ license = custom:Unlicese
makedepends = cargo
depends = openssl
provides = monolith
conflicts = monolith
- source = monolith-2.0.16.tar.gz::https://github.com/Y2Z/monolith/archive/v2.0.16.tar.gz
- sha512sums = 48d9e09a0e9a42a9c0e22c36c42fc06f8c84179a0bc353b101cd72102fb3cc0874f5ae89604056255c9d537d747fca80b1ad8f40eab4bb67d882755225a04938
+ source = monolith-2.0.23.tar.gz::https://github.com/Y2Z/monolith/archive/491185e191b09051f25ca5a0809ee576e42a9d44.tar.gz
+ sha512sums = e507b4639d908457b167b6910196ceb066441527c59bb6737a57327dd97943c2a5673c67b35442cd1f354d67f3c97d2e4b8da4e79ec3ed35e95878ab91dbd78e
pkgname = monolith
diff --git a/PKGBUILD b/PKGBUILD
index 743c2f273adf..34e2f45bee3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=monolith
-pkgver=2.0.16
-pkgrel=2
+pkgver=2.0.23
+_commit=491185e191b09051f25ca5a0809ee576e42a9d44 # Untagged release
+pkgrel=1
pkgdesc='CLI to save web pages as single HTML files'
-arch=(i686 x86_64)
+arch=(x86_64 aarch64)
url=https://github.com/Y2Z/monolith
-license=(custom)
+license=(custom:Unlicese)
depends=(openssl)
makedepends=(cargo)
provides=(monolith)
conflicts=(monolith)
-source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
-sha512sums=('33f554cde4305ae9d01461edd7fadf16aba2ad6bd57f3af321a847314621006c11fb338ebce347c24d9cdc840d49dee89ba134c6c2a6a8bac3e0ac98be489a19')
+source=($pkgname-$pkgver.tar.gz::$url/archive/$_commit.tar.gz)
+sha512sums=('e507b4639d908457b167b6910196ceb066441527c59bb6737a57327dd97943c2a5673c67b35442cd1f354d67f3c97d2e4b8da4e79ec3ed35e95878ab91dbd78e')
build() {
- cd $pkgname-$pkgver
+ cd $pkgname-$_commit
cargo build --release
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname-$_commit
install -D target/release/monolith -t "$pkgdir"/usr/bin
install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname