summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c67e4ee32d1c..5257334a3634 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = moonlight-qt
pkgdesc = GameStream client for PCs (Windows, Mac, and Linux)
- pkgver = 0.3.0
+ pkgver = 0.4.0
pkgrel = 1
url = https://moonlight-stream.com
arch = x86_64
license = GPL
+ makedepends = git
depends = qt5-base
depends = qt5-quickcontrols
depends = qt5-quickcontrols2
+ depends = qt5-svg
+ depends = ffmpeg
optdepends = libva-intel-driver: hardware acceleration for Intel GPUs
- source = moonlight-qt::git+https://github.com/moonlight-stream/moonlight-qt.git
+ source = moonlight-qt::git+https://github.com/moonlight-stream/moonlight-qt.git#tag=v0.4.0
md5sums = SKIP
pkgname = moonlight-qt
diff --git a/PKGBUILD b/PKGBUILD
index febb536b29ba..b0301899f23b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
# Maintainer: Michael Herzberg <{firstname}@{firstinitial}{lastname}.de>
pkgname=moonlight-qt
-pkgver=0.3.0
+pkgver=0.4.0
pkgrel=1
pkgdesc='GameStream client for PCs (Windows, Mac, and Linux)'
arch=('x86_64')
license=('GPL')
url='https://moonlight-stream.com'
-depends=('qt5-base' 'qt5-quickcontrols' 'qt5-quickcontrols2')
+depends=('qt5-base' 'qt5-quickcontrols' 'qt5-quickcontrols2' 'qt5-svg' 'ffmpeg')
+makedepends=('git')
optdepends=('libva-intel-driver: hardware acceleration for Intel GPUs')
-source=($pkgname::"git+https://github.com/moonlight-stream/${pkgname}.git")
+source=($pkgname::"git+https://github.com/moonlight-stream/${pkgname}.git#tag=v${pkgver}")
md5sums=('SKIP')
-pkgver() {
+prepare() {
cd "$pkgname"
- git describe --long --tags | sed 's/^v//;s/-.*//'
+ git submodule update --init --recursive
+ qmake PREFIX="$pkgdir/usr"
}
build() {
cd "$pkgname"
-
- git checkout v${pkgver}
- git submodule update --init --recursive
-
- qmake PREFIX="$pkgdir/usr"
make
}