summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..241af3007dfe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mopidy-api-explorer
+ pkgdesc = Mopidy extension which lets you explore the HTTP API
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/dz0ny/mopidy-api-explorer
+ arch = any
+ license = APACHE
+ makedepends = python2
+ makedepends = python2-setuptools
+ depends = python2
+ depends = mopidy>=0.19
+ source = https://pypi.python.org/packages/source/M/Mopidy-API-Explorer/Mopidy-API-Explorer-1.0.1.tar.gz
+ md5sums = 245a959dddfabccf796507d0ba2bf34a
+
+pkgname = mopidy-api-explorer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15d5828fe788
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Trygve Aaberge <trygveaa+aur at gmail dot com>
+
+pkgname=mopidy-api-explorer
+_pypiname=Mopidy-API-Explorer
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Mopidy extension which lets you explore the HTTP API"
+arch=('any')
+url="https://github.com/dz0ny/mopidy-api-explorer"
+license=('APACHE')
+depends=('python2' 'mopidy>=0.19')
+makedepends=('python2' 'python2-setuptools')
+source=("https://pypi.python.org/packages/source/M/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
+md5sums=('245a959dddfabccf796507d0ba2bf34a')
+
+package() {
+ cd "${srcdir}/${_pypiname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: