summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD25
3 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 520cb3de9132..d4540a2b1ec4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = mopidy-iris
pkgdesc = A Mopidy Web client that utilizes the Spotify and EchoNest frameworks. (Formerly Spotmop)
- pkgver = 3.64.1
+ pkgver = 3.69.3
pkgrel = 1
url = https://github.com/jaedb/iris
arch = any
license = APACHE
- makedepends = python-setuptools
- makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = mopidy>=3
- depends = python-configobj
- depends = python-pylast
+ depends = python-pykka>=2.0.1
+ depends = python-setuptools
optdepends = mopidy-local: local library support
optdepends = mopidy-spotify: spotify support
- source = mopidy-iris-3.64.1.tar.gz::https://pypi.io/packages/source/M/Mopidy-Iris/Mopidy-Iris-3.64.1.tar.gz
- sha256sums = 905493a9b8872ce68b2f2d7e9331b1781cfbf88ced80801c670152338ae34176
+ source = Mopidy-Iris-3.69.3.tar.gz::https://files.pythonhosted.org/packages/source/M/Mopidy-Iris/Mopidy-Iris-3.69.3.tar.gz
+ sha256sums = 3c40179daa62cb1a338a3474e7723bcd061160b783395ef5f4bd106cedabe2be
pkgname = mopidy-iris
diff --git a/.gitignore b/.gitignore
index 4dd009cbcfba..3f6eb47c9c02 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
src/
pkg/
*.log
-*.pkg.tar.xz
+*.pkg.*
*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 55f3479fb1db..eaccc9894c32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,27 @@
# Contributor: evertonstz <evertonjcorreia@gmail.com>
# Contributor: phijor <mail [at] phijor [dot] me>
-_pkgname=iris
-pkgname=mopidy-${_pkgname}
-pkgver=3.64.1
+_name=Mopidy-Iris
+pkgname=mopidy-iris
+pkgver=3.69.3
pkgrel=1
pkgdesc='A Mopidy Web client that utilizes the Spotify and EchoNest frameworks. (Formerly Spotmop)'
arch=('any')
-url="https://github.com/jaedb/${_pkgname}"
+url="https://github.com/jaedb/iris"
license=('APACHE')
-depends=('mopidy>=3' 'python-configobj' 'python-pylast')
-makedepends=('python-setuptools' 'python-pip')
+depends=('mopidy>=3' 'python-pykka>=2.0.1' 'python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
optdepends=('mopidy-local: local library support'
'mopidy-spotify: spotify support')
-source=("${pkgname}-${pkgver}.tar.gz::https://pypi.io/packages/source/M/Mopidy-Iris/Mopidy-Iris-${pkgver}.tar.gz")
-sha256sums=('905493a9b8872ce68b2f2d7e9331b1781cfbf88ced80801c670152338ae34176')
+source=("${_name}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('3c40179daa62cb1a338a3474e7723bcd061160b783395ef5f4bd106cedabe2be')
+
+build() {
+ cd "${_name}-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "${srcdir}/Mopidy-Iris-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ cd "${_name}-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}