summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bfc6dff94b3..5c461e3d1914 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mothur
pkgdesc = A bioinformatics program for analyzing microbial communities.
- pkgver = 1.41.1
+ pkgver = 1.41.2
pkgrel = 1
url = https://www.mothur.org/
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = mothur
makedepends = hdf5
depends = boost-libs
options = !buildflags
- source = https://github.com/mothur/mothur/archive/v.1.41.1.tar.gz
- sha256sums = 09185acb00b424d079ecb7f0d1862d214539654dec116417aa2740f68f17b80f
+ source = https://github.com/mothur/mothur/archive/v1.41.2.tar.gz
+ sha256sums = ac739f537ef1750c0a30c68af396fb189e58fb518b1fd0ae4e905dd93ea50263
pkgname = mothur
diff --git a/PKGBUILD b/PKGBUILD
index 11a40cd77b54..1620a739b9a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=mothur
-pkgver=1.41.1
+pkgver=1.41.2
pkgrel=1
pkgdesc='A bioinformatics program for analyzing microbial communities.'
arch=('x86_64')
@@ -11,17 +11,23 @@ license=('GPL3')
depends=('boost-libs')
makedepends=('boost' 'hdf5')
options=('!buildflags')
-source=("https://github.com/${pkgname}/${pkgname}/archive/v.${pkgver}.tar.gz")
-sha256sums=('09185acb00b424d079ecb7f0d1862d214539654dec116417aa2740f68f17b80f')
+source=("https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('ac739f537ef1750c0a30c68af396fb189e58fb518b1fd0ae4e905dd93ea50263')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ rm filefile.cpp filefile.hpp
+}
build() {
- cd "${pkgname}-v.${pkgver}"
+ cd "${pkgname}-${pkgver}"
make
}
package() {
- cd "${pkgname}-v.${pkgver}"
+ cd "${pkgname}-${pkgver}"
install -Dm755 mothur "${pkgdir}/usr/bin/mothur"
install -Dm755 uchime "${pkgdir}/usr/bin/uchime"