summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD19
3 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8ccf6ad2d07..4c795f0f2c21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
-# Generated by mksrcinfo v8
-# Fri Mar 31 11:08:08 UTC 2017
pkgbase = mothur
- pkgdesc = computational microbial ecology
+ pkgdesc = A bioinformatics program for analyzing microbial communities
pkgver = 1.39.5
- pkgrel = 1
+ pkgrel = 2
url = https://www.mothur.org/
arch = i686
arch = x86_64
license = GPL3
makedepends = boost
depends = boost-libs
- source = mothur-1.39.5.tar.gz::https://github.com/mothur/mothur/archive/v1.39.5.tar.gz
- md5sums = 1f826ea4420e6822fc0db002c5940b92
+ source = https://github.com/mothur/mothur/archive/v1.39.5.tar.gz
+ sha256sums = 9f1cd691e9631a2ab7647b19eb59cd21ea643f29b22cde73d7f343372dfee342
pkgname = mothur
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 42ab3cf03f2d..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
index f9ffb1adbb50..b8dbf4a93783 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
+# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
+# Contributor: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=mothur
pkgver=1.39.5
-pkgrel=1
-pkgdesc="computational microbial ecology"
+pkgrel=2
+pkgdesc="A bioinformatics program for analyzing microbial communities"
arch=('i686' 'x86_64')
url="https://www.mothur.org/"
license=('GPL3')
depends=('boost-libs')
makedepends=('boost')
-
-source=("$pkgname-$pkgver.tar.gz::https://github.com/mothur/mothur/archive/v$pkgver.tar.gz")
+source=(https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('9f1cd691e9631a2ab7647b19eb59cd21ea643f29b22cde73d7f343372dfee342')
prepare() {
- cd $srcdir/$pkgname-$pkgver
+ cd $pkgname-$pkgver
sed -e 's|BOOST_LIBRARY_DIR="\\"Enter_your_boost_library_path_here\\""|BOOST_LIBRARY_DIR = /usr/lib|' \
-e 's|BOOST_INCLUDE_DIR="\\"Enter_your_boost_include_path_here\\""|BOOST_INCLUDE_DIR = /usr/include|' \
@@ -21,16 +22,14 @@ prepare() {
}
build() {
- cd $srcdir/$pkgname-$pkgver
+ cd $pkgname-$pkgver
make
}
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd $pkgname-$pkgver
install -Dm755 mothur $pkgdir/usr/bin/mothur
install -Dm755 uchime $pkgdir/usr/bin/uchime
}
-
-md5sums=('1f826ea4420e6822fc0db002c5940b92')