summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54aa9e4ece16..47a52bf2cbb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mothur
pkgdesc = A bioinformatics program for analyzing microbial communities.
- pkgver = 1.45.3
+ pkgver = 1.46.0
pkgrel = 1
url = https://www.mothur.org/
arch = x86_64
@@ -8,8 +8,7 @@ pkgbase = mothur
makedepends = boost
makedepends = hdf5
depends = boost-libs
- source = mothur-1.45.3.tar.gz::https://github.com/mothur/mothur/archive/v1.45.3.tar.gz
- sha256sums = 865317569260ab7fa8fde2cbe00bcc05e6402dcd97267615d863ede145f381e8
+ source = mothur-1.46.0.tar.gz::https://github.com/mothur/mothur/archive/v1.46.0.tar.gz
+ sha256sums = 0bb833b82c8841dca8cecfa58c93d537ec55f4a66d0def40916668a18baf6424
pkgname = mothur
-
diff --git a/PKGBUILD b/PKGBUILD
index b39e1d990473..d6486a2107eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=mothur
-pkgver=1.45.3
+pkgver=1.46.0
pkgrel=1
pkgdesc='A bioinformatics program for analyzing microbial communities.'
arch=('x86_64')
@@ -11,15 +11,16 @@ license=('GPL3')
depends=('boost-libs')
makedepends=('boost' 'hdf5')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('865317569260ab7fa8fde2cbe00bcc05e6402dcd97267615d863ede145f381e8')
+sha256sums=('0bb833b82c8841dca8cecfa58c93d537ec55f4a66d0def40916668a18baf6424')
prepare() {
cd "${pkgname}-${pkgver}"
- sed -i '87d' source/mothur.h
- sed -i 's/skipUchime),/skipUchime), source\/,/g' Makefile
- sed -i 's/1.45.2/1.45.3/g' Makefile Makefile_cluster
-# rm splitkmerdist.cpp splitkmerdist.hpp
+ # I hate this so much.
+ sed -i '87d' source/mothur.h
+ sed -i '13 i \#include <memory>' source/writer.h
+ sed -i 's/skipUchime),/skipUchime), source\/,/g' Makefile
+ sed -i 's/CXXFLAGS = -O3/CXXFLAGS = -O3 -std=c++11/' source/uchime_src/makefile
}
build() {