summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD72
2 files changed, 22 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab94f481fa62..072d96352844 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,10 @@
pkgbase = movie-monad
- pkgdesc = A free and simple to use video player built with Haskell.
- pkgver = 0.0.4.0_0
+ pkgdesc = A free and simple to use video player made with Haskell.
+ pkgver = 0.0.5.0_0
pkgrel = 1
url = https://github.com/lettier/movie-monad
arch = x86_64
license = BSD3
- makedepends = make
- makedepends = wget
- makedepends = gobject-introspection
- makedepends = git
- makedepends = gmp
- makedepends = zlib
- makedepends = ncurses
depends = gtk3
depends = gstreamer
depends = gst-libav
@@ -19,10 +12,8 @@ pkgbase = movie-monad
depends = gst-plugins-base
depends = gst-plugins-good
depends = gst-plugins-bad
- options = strip
- options = staticlibs
- source = http://hackage.haskell.org/packages/archive/movie-monad/0.0.4.0/movie-monad-0.0.4.0.tar.gz
- md5sums = 3990015342dce1a7fc6d404dae72f093
+ source = https://www.github.com/lettier/movie-monad/releases/download/0.0.5.0/movie-monad-linux-0.0.5.0.tar.gz
+ md5sums = fc6775656d866772b557438aff465f4b
pkgname = movie-monad
diff --git a/PKGBUILD b/PKGBUILD
index 5b1ae039f2d3..aa768992a359 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,67 +1,31 @@
# Maintainer: Lettier <movie_monad_aur a@@at@t lettier dd.ot..t ccommm>
-_hkgname="movie-monad"
-_ver=0.0.4.0
+_name="movie-monad"
+_ver=0.0.5.0
_xrev=0
-_tree_hash="89a10fc8f4e4248958347cf182cb8f6f04e82707"
-pkgname="movie-monad"
+pkgname=${_name}
pkgver=${_ver}_${_xrev}
pkgrel=1
-pkgdesc="A free and simple to use video player built with Haskell."
-url="https://github.com/lettier/${pkgname}"
+pkgdesc="A free and simple to use video player made with Haskell."
+url="https://github.com/lettier/${_name}"
license=("BSD3")
arch=("x86_64")
-makedepends=("make" "wget" "gobject-introspection" "git" "gmp" "zlib" "ncurses")
+makedepends=()
depends=("gtk3" "gstreamer" "gst-libav" "gst-plugins-base-libs" "gst-plugins-base" "gst-plugins-good" "gst-plugins-bad")
-options=("strip" "staticlibs")
-source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${_ver}/${_hkgname}-${_ver}.tar.gz")
-md5sums=('3990015342dce1a7fc6d404dae72f093')
-
-build() {
- mkdir -p "${HOME}/.local/bin"
- cd "${srcdir}"
-
- if [ ! `command -v stack` ]; then
- # https://github.com/commercialhaskell/stack/issues/257#issuecomment-241898802
- git clone https://aur.archlinux.org/libtinfo5.git
- cd libtinfo5
- makepkg -sic
-
- cd "${srcdir}"
-
- git clone https://aur.archlinux.org/stack-bin.git
- cd "stack-bin"
- makepkg -sic
-
- cd "${srcdir}"
-
- # https://github.com/commercialhaskell/stack/issues/3509#issuecomment-338786743
- mkdir -p "${HOME}/.stack/"
- touch "${HOME}/.stack/config.yaml"
- echo "ghc-build: nopie" >> "${HOME}/.stack/config.yaml"
- fi
-
- cd "${srcdir}/${_hkgname}-${_ver}"
- make cabal_install_relocatable_executable
-}
+options=()
+source=("https://www.github.com/lettier/${_name}/releases/download/${_ver}/${_name}-linux-${_ver}.tar.gz")
+md5sums=('fc6775656d866772b557438aff465f4b')
package() {
- cd "${srcdir}/${_hkgname}-${_ver}"
- wget "https://raw.githubusercontent.com/lettier/${pkgname}/${_tree_hash}/packaging/linux/generic/${pkgname}.desktop" -O "${pkgname}.desktop"
- wget "https://raw.githubusercontent.com/lettier/${pkgname}/${_tree_hash}/packaging/linux/generic/${pkgname}.svg" -O "${pkgname}.svg"
- _GHC_VER=`stack ghc -- --numeric-version`
+ cd "${srcdir}/${_name}-linux-${_ver}"
mkdir -p \
- "${pkgdir}/usr/bin" \
- "${pkgdir}/usr/lib/x86_64-linux-ghc-${_GHC_VER}" \
- "${pkgdir}/usr/share/doc/${pkgname}" \
- "${pkgdir}/usr/share/x86_64-linux-ghc-${_GHC_VER}/${pkgname}-${_ver}" \
- "${pkgdir}/usr/share/icons/hicolor/scalable/apps" \
- "${pkgdir}/usr/share/applications"
- cp ".cabal-sandbox/bin/${pkgname}" "${pkgdir}/usr/bin/"
- cp ".cabal-sandbox/lib/x86_64-linux-ghc-${_GHC_VER}/"*.so "${pkgdir}/usr/lib/x86_64-linux-ghc-${_GHC_VER}/"
- cp -R ".cabal-sandbox/share/x86_64-linux-ghc-${_GHC_VER}/${pkgname}-${_ver}" "${pkgdir}/usr/share/x86_64-linux-ghc-${_GHC_VER}/"
- cp -R ".cabal-sandbox/share/doc/x86_64-linux-ghc-${_GHC_VER}/"* "${pkgdir}/usr/share/doc/${pkgname}/"
- cp "${pkgname}.desktop" "${pkgdir}/usr/share/applications/"
- cp "${pkgname}.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/"
+ "${pkgdir}/opt/${_name}-linux-${_ver}/" \
+ "${pkgdir}/usr/bin/" \
+ "${pkgdir}/usr/share/applications/" \
+ "${pkgdir}/usr/share/icons/hicolor/scalable/apps/"
+ cp -RP . "${pkgdir}/opt/${_name}-linux-${_ver}/"
+ cp "./share/applications/${_name}.desktop" "${pkgdir}/usr/share/applications/"
+ cp "./share/icons/hicolor/scalable/apps/${_name}-icon.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/"
+ ln -s "/opt/${_name}-linux-${_ver}/bin/${_name}" "${pkgdir}/usr/bin/${_name}"
}