summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD16
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84f76dfe7f6b..b5e2df1d43fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# 金 8月 19 11:20:42 UTC 2016
+# 月 10月 3 12:22:24 UTC 2016
pkgbase = mozc
pkgdesc = A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)
- pkgver = 2.18.2548.102
+ pkgver = 2.18.2612.102
pkgrel = 1
url = http://code.google.com/p/mozc/
arch = i686
@@ -17,12 +17,12 @@ pkgbase = mozc
depends = qt4
depends = ibus>=1.4.1
depends = zinnia
- source = mozc::git+https://github.com/google/mozc.git#commit=5d0e6164f5e88248990fa9488eef42dc7f042c8b
- source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/x-ken-all-201607.zip
- source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/jigyosyo-201607.zip
+ source = mozc::git+https://github.com/google/mozc.git#commit=2315f957d1785130c2ed196e141a330b0857b065
+ source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/x-ken-all-201609.zip
+ source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/jigyosyo-201609.zip
sha1sums = SKIP
- sha1sums = 0679ed0cdda02fcf43dc7562e6de54228adfc8cb
- sha1sums = f50936e8f21f5c727d3ebd73583ee0fd900bc7d0
+ sha1sums = 7fc1c5e2487e47db84e2791a88085c1d6c8782cc
+ sha1sums = 3d012569963b9359d2d267216f78c1a07a395065
pkgname = mozc
pkgdesc = A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)
@@ -43,7 +43,7 @@ pkgname = emacs-mozc
arch = i686
arch = x86_64
groups = mozc-im
- depends = mozc=2.18.2548.102
+ depends = mozc=2.18.2612.102
depends = emacs
conflicts = emacs-mozc-bin
replaces = emacs-mozc-bin
@@ -53,6 +53,6 @@ pkgname = ibus-mozc
arch = i686
arch = x86_64
groups = mozc-im
- depends = mozc=2.18.2548.102
+ depends = mozc=2.18.2612.102
depends = ibus>=1.4.1
diff --git a/PKGBUILD b/PKGBUILD
index b358516d33a9..1d10185f2111 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,12 +28,12 @@ _bldtype=Release
#*************************************************************
_zipcoderel=201609
-_mozcrev=5d0e6164f5e88248990fa9488eef42dc7f042c8b
+_mozcrev=2315f957d1785130c2ed196e141a330b0857b065
pkgbase=mozc
pkgname=mozc
true && pkgname=('mozc')
-pkgver=2.18.2548.102
+pkgver=2.18.2612.102
pkgrel=1
arch=('i686' 'x86_64')
url="http://code.google.com/p/mozc/"
@@ -61,7 +61,7 @@ fi
pkgver() {
- . "${srcdir}/${pkgbase}/src/data/version/mozc_version_template.txt"
+ . "${srcdir}/${pkgbase}/src/data/version/mozc_version_template.bzl"
printf "%s.%s.%s.%s" $MAJOR $MINOR $BUILD $REVISION
}
@@ -84,9 +84,11 @@ prepare() {
if [[ "$_zipcode" == "yes" ]]; then
msg "Generating zip code dict seed..."
cd "$srcdir"
- python2 ${pkgbase}/src/dictionary/gen_zip_code_seed.py \
- --zip_code=x-ken-all.csv --jigyosyo=JIGYOSYO.CSV \
- >> ${pkgbase}/src/data/dictionary_oss/dictionary09.txt
+ PYTHONPATH="${PYTHONPATH}:${srcdir}/${pkgbase}/src/" \
+ python2 mozc/src/dictionary/gen_zip_code_seed.py \
+ --zip_code=x-ken-all.csv \
+ --jigyosyo=JIGYOSYO.CSV \
+ >> "${srcdir}/${pkgbase}/src/data/dictionary_oss/dictionary09.txt"
msg "Done."
fi
@@ -121,7 +123,7 @@ build() {
unset CC CC_host CC_target CXX CXX_host CXX_target LINK AR AR_host AR_target \
NM NM_host NM_target READELF READELF_host READELF_target
QTDIR=$_qt4dir GYP_DEFINES="document_dir=/usr/share/licenses/${pkgbase}" \
- python2 build_mozc.py gyp
+ python2 build_mozc.py gyp --target_platform=Linux
python2 build_mozc.py build -c $_bldtype $_targets
if [[ "$_ibus_mozc" == "yes" ]]; then