summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD2
-rwxr-xr-xmod-generate-dictionary.sh16
2 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6d929b24063..bd8104609cf9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -84,7 +84,7 @@ pkgrel=1
arch=('i686' 'x86_64')
url="http://www.geocities.jp/ep3797/mozc-ut2.html"
license=('BSD' 'GPL' 'CC-BY-SA' 'custom')
-makedepends=('python2' 'ruby' 'git' 'ninja' 'clang')
+makedepends=('python2' 'ruby' 'git' 'ninja' 'clang' 'qt4')
source=(
mozc::git+https://github.com/google/mozc.git#commit=${_mozcrev}
http://downloads.sourceforge.net/project/pnsft-aur/mozc/mozcdic-ut2-${_utdicver}.tar.bz2
diff --git a/mod-generate-dictionary.sh b/mod-generate-dictionary.sh
index 157d14cd03d6..a1638c63efbc 100755
--- a/mod-generate-dictionary.sh
+++ b/mod-generate-dictionary.sh
@@ -2,7 +2,7 @@
[[ ! -f generate-dictionary.sh ]] && { echo "generate-dictionary.sh not found."; exit 1; }
-sed -i \
+sed -i.bak \
-e '1s/sh/sh -e/' \
-e 's/ruby \(.*\)/ruby -EUTF-8 \1/g' \
generate-dictionary.sh \
@@ -13,17 +13,17 @@ sed -i \
# 3) Specify $srcdir/JIGYOSYO.CSV
# 4) Modify mozc-\$MOZCVER to mozc
# 5) Comment out making xz archive
-sed -i \
+sed -i.bak \
-e 's/^\(MOZCVER=.*\|DICVER=.*\|NICODIC=.*\)/#&/g' \
- -e '/rm -rf mozc-$MOZCVER/s/^/#/i' \
- -e '/echo "extract official mozc..."/,+1s/^/#/ig' \
- -e '/rm -f \*\.zip/,+6s/^/#/ig' \
+ -e '/rm -rf mozc-$MOZCVER/s/^/#/g' \
+ -e '/echo "extract official mozc..."/,+1s/^/#/g' \
+ -e '/rm -f \*\.zip/,+6s/^/#/g' \
-e '/cd chimei/a cp -f ../../KEN_ALL.CSV .' \
-e 's|JIGYOSYO.CSV|../../JIGYOSYO.CSV|' \
-e 's|mozc-\$MOZCVER|mozc|g' \
- -e '/# compress mozc-ut/,+4s/^/#/ig' \
+ -e '/# compress mozc-ut/,+4s/^/#/g' \
generate-dictionary.sh
-sed -i \
- -e '/^\(#\|ruby\|$\)/!s/^/#/ig' \
+sed -i.bak \
+ -e '/^\(#\|ruby\|$\)/!s/^/#/g' \
edict-katakana-english/generate-dictionary.sh