summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf93e86d902f..b23e9553cbc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
pkgbase = mozilla-extension-gnotifier-git
pkgdesc = Add-on for Firefox and Thunderbird to enable integration with GNOME native notification system.
pkgver = 1.9.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mkiol/GNotifier
arch = any
license = GPL3
+ makedepends = nodejs-jpm
+ makedepends = unzip
makedepends = git
makedepends = rasqal
depends = libnotify
diff --git a/PKGBUILD b/PKGBUILD
index b493a5ba00cf..c740a884d048 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,13 @@
pkgname=mozilla-extension-gnotifier-git
pkgver=1.9.5
-pkgrel=1
+pkgrel=2
pkgdesc='Add-on for Firefox and Thunderbird to enable integration with GNOME native notification system.'
url='https://github.com/mkiol/GNotifier'
arch=('any')
license=('GPL3')
depends=('libnotify')
+makedepends=('nodejs-jpm' 'unzip')
optdepends=(firefox thunderbird)
makedepends+=('git')
@@ -47,6 +48,9 @@ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
build() {
cp -r --reflink=auto source/* .
rm -r xpi misc *.md win8* source
+ jpm xpi
+ unzip -o *.xpi
+ rm *.xpi
}
eval "package_$pkgname()" '{