summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96cac9473d5c..79c2817652a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mozilla-extension-stylish
pkgdesc = Customize your favorite web sites with user styles.
pkgver = 2.0.7
- pkgrel = 1
+ pkgrel = 2
url = https://userstyles.org/
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index f7610a9b4f1a..b0bfa7de39cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=mozilla-extension-stylish
pkgver=2.0.7
-pkgrel=1
+pkgrel=2
pkgdesc='Customize your favorite web sites with user styles.'
url='https://userstyles.org/'
license=('GPL')
@@ -63,9 +63,18 @@ for target in "${optdepends[@]}"; do
done
optdepends=()
+
version-range() {
- local emid=$(emid $1)
- echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ if [ -z "$(sparql "?x em:type ?type. filter(?type in ('2', '64'))")" ] ||
+ [ -n "$(sparql "?x em:strictCompatibility 'true'")" ] ||
+ { [ -e chrome.manifest ] &&
+ grep '^binary-component[ \t]' chrome.manifest ; }
+ then
+ local emid=$(emid $1)
+ echo "$1>$(version min $emid)" "$1<$(version max $emid)"
+ else
+ echo "$1>$(version min $(emid $1))"
+ fi
}
emid() {