summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO53
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD106
-rw-r--r--mozillavpn.install34
4 files changed, 141 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc680a3594fb..f65e93cc256c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,40 @@
pkgbase = mozillavpn
- pkgdesc = A fast, secure and easy to use VPN. Built by the makers of Firefox.
- pkgver = 2.0.3
+ pkgdesc = Fast, secure, and easy to use VPN from the makers of Firefox
+ pkgver = 2.21.0
pkgrel = 1
- url = https://vpn.mozilla.org/
- arch = i686
+ url = https://vpn.mozilla.org
+ install = mozillavpn.install
arch = x86_64
- license = GPL
- makedepends = qt5-tools
- depends = polkit
- depends = qt5-charts
- depends = qt5-declarative
- depends = qt5-graphicaleffects
- depends = qt5-imageformats
- depends = qt5-networkauth
- depends = qt5-quickcontrols2
- depends = qt5-svg
+ license = MPL2
+ makedepends = cargo
+ makedepends = clang
+ makedepends = cmake
+ makedepends = flex
+ makedepends = go
+ makedepends = python-lxml
+ makedepends = python-yaml
+ makedepends = qt6-tools
+ depends = dbus
+ depends = freetype2
depends = hicolor-icon-theme
+ depends = libtiff
+ depends = libxcb
+ depends = libxdmcp
+ depends = libxmu
+ depends = libxrender
+ depends = polkit
+ depends = qt6-5compat
+ depends = qt6-charts
+ depends = qt6-declarative
+ depends = qt6-imageformats
+ depends = qt6-networkauth
+ depends = qt6-shadertools
+ depends = qt6-svg
+ depends = qt6-websockets
depends = wireguard-tools
- depends = WIREGUARD-MODULE
- conflicts = mozilla-vpn-client
- replaces = mozilla-vpn-client
- source = https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/2.0.3-focal1/mozillavpn_2.0.3.orig.tar.gz
- sha256sums = 4d3d557528812a3fd8401d31ef97c49e5d3cb0a4a9679dd0fea219cb3c8e640e
+ optdepends = qt6-wayland: for Wayland support
+ options = !lto
+ source = https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/2.21.0-mantic1/mozillavpn_2.21.0.orig.tar.gz
+ sha256sums = 406dde90e90cbc2419f66b6b822314b02936ff089ef15ae08008f2a67c77b5b5
pkgname = mozillavpn
-
diff --git a/.gitignore b/.gitignore
index 1506182b09fa..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-/*.tar.gz
-/*.pkg.tar.*
-/pkg/
-/src/
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 4dddd11ee593..dd73a6a76cc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,78 @@
-# Maintainer: Tavian Barnes <tavianator@tavianator.com>
+# Maintainer XavierCLL <xavier.corredor.llano (a) gmail.com>
+# Contributor: Utsav <aur (a) utsav2 [.] dev>
+# Contributor: Tavian Barnes <tavianator@tavianator.com>
+# Contributor: jhorcl
+# Contributor: flbzh <frederic_lebouc (a) yahoo.fr>
+# Contributor: RafaƂ Wyszomirski <m6vuthzbw at mozmail dot com>
+
+## useful urls:
+# https://vpn.mozilla.org
+# https://github.com/mozilla-mobile/mozilla-vpn-client
+# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
+
pkgname=mozillavpn
-pkgver=2.0.3
+pkgver=2.21.0
pkgrel=1
-epoch=
-pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
-arch=('i686' 'x86_64')
-url="https://vpn.mozilla.org/"
-license=('GPL')
-groups=()
-depends=('polkit'
- 'qt5-charts'
- 'qt5-declarative'
- 'qt5-graphicaleffects'
- 'qt5-imageformats'
- 'qt5-networkauth'
- 'qt5-quickcontrols2'
- 'qt5-svg'
- 'hicolor-icon-theme'
- 'wireguard-tools'
- 'WIREGUARD-MODULE')
-makedepends=('qt5-tools')
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=('mozilla-vpn-client')
-replaces=('mozilla-vpn-client')
-backup=()
-options=()
-install=
-changelog=
-source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/$pkgname/$pkgver-focal1/${pkgname}_${pkgver}.orig.tar.gz")
-noextract=()
-sha256sums=('4d3d557528812a3fd8401d31ef97c49e5d3cb0a4a9679dd0fea219cb3c8e640e')
-validpgpkeys=()
+pkgdesc="Fast, secure, and easy to use VPN from the makers of Firefox"
+arch=('x86_64')
+url="https://vpn.mozilla.org"
+license=('MPL2')
+options=('!lto')
+depends=(
+ 'dbus'
+ 'freetype2'
+ 'hicolor-icon-theme'
+ 'libtiff'
+ 'libxcb'
+ 'libxdmcp'
+ 'libxmu'
+ 'libxrender'
+ 'polkit'
+ 'qt6-5compat'
+ 'qt6-charts'
+ 'qt6-declarative'
+ 'qt6-imageformats'
+ 'qt6-networkauth'
+ 'qt6-shadertools'
+ 'qt6-svg'
+ 'qt6-websockets'
+ 'wireguard-tools'
+)
+makedepends=(
+ 'cargo'
+ 'clang'
+ 'cmake'
+ 'flex'
+ 'go'
+ 'python-lxml'
+ 'python-yaml'
+ 'qt6-tools'
+)
+optdepends=(
+ 'qt6-wayland: for Wayland support'
+)
+
+install=mozillavpn.install
+
+_debian_series="mantic1"
+_dl_url="https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn"
+_pkgsrc="$pkgname-$pkgver"
+source=("$_dl_url/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz")
+sha256sums=('406dde90e90cbc2419f66b6b822314b02936ff089ef15ae08008f2a67c77b5b5')
build() {
- qmake PREFIX=/usr CONFIG+=production CONFIG-=debug CONFIG+=release CONFIG-=debug_and_release
- make
+ local _cmake_options=(
+ -B build
+ -S "$_pkgsrc"
+ -DCMAKE_BUILD_TYPE=Release
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ -Wno-dev
+ )
+
+ cmake "${_cmake_options[@]}"
+ cmake --build build
}
package() {
- make INSTALL_ROOT="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
diff --git a/mozillavpn.install b/mozillavpn.install
new file mode 100644
index 000000000000..13a909008837
--- /dev/null
+++ b/mozillavpn.install
@@ -0,0 +1,34 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${BLUE}==>${BOLD} $1${ALL_OFF}\n"
+}
+
+note1() {
+ printf "${BLUE}==>${YELLOW} NOTE:${BOLD} $1${ALL_OFF}\n"
+}
+
+note2() {
+ printf "${BLUE}==> ${BOLD} $1${ALL_OFF}\n"
+}
+
+ALL_OFF="$(tput sgr0)"
+BOLD="${ALL_OFF}$(tput bold)"
+BLACK="${BOLD}$(tput setaf 0)"
+RED="${BOLD}$(tput setaf 1)"
+GREEN="${BOLD}$(tput setaf 2)"
+YELLOW="${BOLD}$(tput setaf 3)"
+BLUE="${BOLD}$(tput setaf 4)"
+MAGENTA="${BOLD}$(tput setaf 5)"
+CYAN="${BOLD}$(tput setaf 6)"
+WHITE="${BOLD}$(tput setaf 7)"
+
+post_install() {
+ note1 'Enable and start the Mozilla VPN daemon with:'
+ note2 ' systemctl enable mozillavpn.service'
+ note2 ' systemctl start mozillavpn.service'
+}
+
+post_upgrade() {
+ note1 'Restart the Mozilla VPN daemon with:'
+ note2 ' systemctl restart mozillavpn.service'
+}