summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD45
2 files changed, 29 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae3978c34ecf..5752c6fe90c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = mozjpeg
- pkgdesc = JPEG image codec with accelerated baseline decoding and superior encoding
- pkgver = 4.1.4
+ pkgdesc = Improved JPEG encoder
+ pkgver = 4.1.5
pkgrel = 1
url = https://github.com/mozilla/mozjpeg
arch = i686
arch = x86_64
arch = armv7h
- license = BSD
+ license = BSD-3-Clause-Modification
+ license = IJG
+ license = Zlib
makedepends = nasm
makedepends = cmake
- depends = glibc
depends = libpng
provides = libjpeg
provides = libjpeg.so
@@ -19,7 +20,7 @@ pkgbase = mozjpeg
conflicts = mozjpeg-git
conflicts = turbojpeg
conflicts = libjpeg-turbo
- source = mozjpeg-4.1.4.tar.gz::https://github.com/mozilla/mozjpeg/archive/v4.1.4.tar.gz
- sha1sums = 6cc6e0ae25197704407e74d5f7445027dc8a64d5
+ source = https://github.com/mozilla/mozjpeg/archive/v4.1.5.tar.gz
+ sha256sums = 9fcbb7171f6ac383f5b391175d6fb3acde5e64c4c4727274eade84ed0998fcc1
pkgname = mozjpeg
diff --git a/PKGBUILD b/PKGBUILD
index 19a1110f6e89..cb9bd881a2f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,45 @@
-# Maintainer: afontenot <adam.m.fontenot@gmail.com>
+# Contributor: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+# Contributor: afontenot <adam.m.fontenot@gmail.com>
# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: Simone Sclavi 'Ito' <darkhado@gmail.com>
# Contributor: N30N <archlinux@alunamation.com>
-pkgname="mozjpeg"
-pkgver=4.1.4
+pkgname=mozjpeg
+pkgver=4.1.5
pkgrel=1
-pkgdesc="JPEG image codec with accelerated baseline decoding and superior encoding"
+pkgdesc="Improved JPEG encoder"
url="https://github.com/mozilla/mozjpeg"
-license=("BSD")
+license=("BSD-3-Clause-Modification" "IJG" "Zlib")
arch=("i686" "x86_64" "armv7h")
-depends=("glibc" "libpng")
+depends=("libpng")
makedepends=("nasm" "cmake")
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha1sums=('ffb05e8db04b3521a450e651bd5db6ce7656c60c')
-
provides=("libjpeg" "libjpeg.so" "turbojpeg" "libjpeg-turbo")
conflicts=("libjpeg" "mozjpeg-git" "turbojpeg" "libjpeg-turbo")
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('9fcbb7171f6ac383f5b391175d6fb3acde5e64c4c4727274eade84ed0998fcc1')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -DENABLE_STATIC=FALSE -DPNG_SUPPORTED=TRUE -DWITH_JPEG8=TRUE .
- make
+ cd mozjpeg-$pkgver
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -DENABLE_STATIC=FALSE \
+ -DPNG_SUPPORTED=TRUE -DWITH_JPEG8=TRUE .
+ make
}
# There are a lot of tests: if you don't want to run them, you or
# your AUR helper should use `makepkg --nocheck`.
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make test
+ cd mozjpeg-$pkgver
+ make test ||:
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make \
- DESTDIR="${pkgdir}" \
- docdir="/usr/share/doc/${pkgname}" \
- exampledir="/usr/share/doc/${pkgname}" \
+ cd mozjpeg-$pkgver
+ make \
+ DESTDIR="$pkgdir" \
+ docdir="/usr/share/doc/mozjpeg" \
+ exampledir="/usr/share/doc/mozjpeg" \
install
-
- install -D LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -m644 jpegint.h "${pkgdir}/usr/include"
+ install -D LICENSE.md "$pkgdir/usr/share/licenses/mozjpeg/LICENSE"
+ install -m644 jpegint.h "$pkgdir/usr/include"
}