summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
-rw-r--r--mozplugger.install15
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dc9c1eab66c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mozplugger
+ pkgdesc = A Mozilla & Firefox multimedia plugin.
+ pkgver = 2.1.6
+ pkgrel = 1
+ url = http://mozplugger.mozdev.org
+ install = mozplugger.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = m4
+ depends = libx11
+ backup = etc/mozpluggerrc
+ source = http://mozplugger.mozdev.org/files/mozplugger-2.1.6.tar.gz
+ sha256sums = 294cf06ad37b8d89e57ee9c4dc9e7549fd1b0dcec9769171d65dad36099e5fef
+
+pkgname = mozplugger
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92e9f2b5956f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: fs4000 <matthias_dienstbier[at]yahoo[dot]de>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Todd Musall <tmusall@comcast.net>
+# Contributor: David Manouchehri <d@32t.ca>
+
+pkgname=mozplugger
+_pkgname=mozplugger
+pkgver=2.1.6
+pkgrel=1
+pkgdesc="A Mozilla & Firefox multimedia plugin."
+arch=('i686' 'x86_64')
+url="http://mozplugger.mozdev.org"
+license=('GPL')
+depends=('m4' 'libx11')
+backup=('etc/mozpluggerrc')
+install=mozplugger.install
+source=($url/files/mozplugger-$pkgver.tar.gz)
+sha256sums=('294cf06ad37b8d89e57ee9c4dc9e7549fd1b0dcec9769171d65dad36099e5fef')
+
+build() {
+ cd $_pkgname-$pkgver
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ #--enable-always-xembed
+ # uncomment the preceding line to get mozplugger running in Chromium
+ # this will always use Xembed which kills keyboard focus
+
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ # doesn't work anymore
+ #make install root="$pkgdir"
+
+ install -Dm644 mozpluggerrc "$pkgdir/etc/mozpluggerrc"
+ install -d "$pkgdir/usr/bin/"
+ install -m755 mozplugger-{helper,controller,linker,update} "$pkgdir/usr/bin/"
+ install -Dm755 mozplugger.so "$pkgdir/usr/lib/mozilla/plugins/mozplugger.so"
+ install -Dm644 mozplugger.7 "$pkgdir/usr/share/man/man7/mozplugger.7"
+}
diff --git a/mozplugger.install b/mozplugger.install
new file mode 100644
index 000000000000..ea6122de4ad7
--- /dev/null
+++ b/mozplugger.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo "
+==> You may need to delete your local
+==> ~/.mozilla/firefox/<profile-dir>/pluginreg.dat file for mozplugger to be
+==> enabled correctly after you update it. (It will get regenerated).
+==> To add more helpers, edit /etc/mozpluggerrc.
+==> The window name can be obtained using the utility xprop(1x).
+==> Type "xprop WM_CLASS" and click on a window."
+}
+
+post_upgrade() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: