summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
2 files changed, 35 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 510a31762c9e..ce14cae2477e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
-# Generated by mksrcinfo v8
-# Wed Apr 5 08:17:05 UTC 2017
pkgbase = mp3directcut
pkgdesc = fast audio editor and recorder for mp3 with no need to decompress
- pkgver = 2.23
+ pkgver = 2.36
pkgrel = 2
- url = http://mpesch3.de1.cc/mp3dc.html
+ url = https://mpesch3.de/index.html
arch = i686
arch = x86_64
license = FREEWARE
+ depends = wine
+ source = http://ftp.elf.stuba.sk/pub/pc/sound/mp3dc236.exe
source = mp3directcut
source = mp3directcut.desktop
source = mp3dcicon.png
- source = http://ftp.elf.stuba.sk/pub/pc/sound/mp3dc223.exe
- md5sums = 31de44159649baddf5c7b6936b87133f
- md5sums = 910ada5caa9b0ea67a88bfc7ffe9c237
- md5sums = 81a5bbd5789094b4bf5822791826c162
- md5sums = d8a565b1db253608f96f2a40ceae9c8a
+ sha256sums = 406018fc3e4b3aa13b963706c62ab0a65889ad8d1cfa15c9ceb46d4c27c36f71
+ sha256sums = d0aa5b02aa6e99a926238747e4a16aae9a7aab6e25612fed0ee46b4cd949c34d
+ sha256sums = 99249e0b1e64c670aac164be5cf0fda5ba16878ce58ae7180d284abfa6d9df33
+ sha256sums = 178d703eb9958990d6b53b0da34e91b21bfed20316ad61a25b94c93f2e09739c
+ depends_i686 = mpg123
+ optdepends_i686 = libpulse: PulseAudio plugin
+ depends_x86_64 = lib32-mpg123
+ optdepends_x86_64 = lib32-libpulse: PulseAudio plugin
pkgname = mp3directcut
-
diff --git a/PKGBUILD b/PKGBUILD
index 1de002d79ceb..8c6b46b31bc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,44 @@
-# Maintainer: Filip <fila pruda com>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Filip <fila pruda com>
+
pkgname=mp3directcut
-pkgver=2.23
-_downver=223
+pkgver=2.36
pkgrel=2
pkgdesc="fast audio editor and recorder for mp3 with no need to decompress"
arch=('i686' 'x86_64')
-url="http://mpesch3.de1.cc/mp3dc.html"
+url="https://mpesch3.de/index.html"
license=('FREEWARE')
-[ "$CARCH" = "i686" ] && depends=(wine mpg123)
-[ "$CARCH" = "x86_64" ] && depends=(wine lib32-mpg123)
-
-[ "$CARCH" = "i686" ] && optdepends=('libpulse: PulseAudio plugin')
-[ "$CARCH" = "x86_64" ] && optdepends=('lib32-libpulse: PulseAudio plugin')
+depends=(wine)
+depends_i686=(mpg123)
+depends_x86_64=(lib32-mpg123)
+optdepends_i686=('libpulse: PulseAudio plugin')
+optdepends_x86_64=('lib32-libpulse: PulseAudio plugin')
+source=(http://ftp.elf.stuba.sk/pub/pc/sound/mp3dc${pkgver/.}.exe
+ mp3directcut
+ mp3directcut.desktop
+ mp3dcicon.png)
+sha256sums=('406018fc3e4b3aa13b963706c62ab0a65889ad8d1cfa15c9ceb46d4c27c36f71'
+ 'd0aa5b02aa6e99a926238747e4a16aae9a7aab6e25612fed0ee46b4cd949c34d'
+ '99249e0b1e64c670aac164be5cf0fda5ba16878ce58ae7180d284abfa6d9df33'
+ '178d703eb9958990d6b53b0da34e91b21bfed20316ad61a25b94c93f2e09739c')
-makedepends=()
-source=(mp3directcut mp3directcut.desktop mp3dcicon.png http://ftp.elf.stuba.sk/pub/pc/sound/mp3dc$_downver.exe)
-#http://free-pc.ru/download/mp3DC$_downver.exe
-md5sums=(
- '31de44159649baddf5c7b6936b87133f' '910ada5caa9b0ea67a88bfc7ffe9c237'
- '81a5bbd5789094b4bf5822791826c162' 'd8a565b1db253608f96f2a40ceae9c8a')
package() {
-
#bin
install -Dm755 "mp3directcut" "$pkgdir/usr/bin/mp3directcut"
-
+
#app
install -d -m755 "$pkgdir/usr/share/mp3directcut"
install -m644 "mp3DirectCut.exe" "$pkgdir/usr/share/mp3directcut"
-
+
install -d -m755 "$pkgdir/usr/share/mp3directcut/Languages"
cp -r "Languages/." "$pkgdir/usr/share/mp3directcut/Languages"
-
+
#.desktop icon
install -Dm644 "mp3directcut.desktop" "$pkgdir/usr/share/applications/mp3directcut.desktop"
install -Dm644 "mp3dcicon.png" "$pkgdir/usr/share/pixmaps/mp3directcut.png"
-
+
#docs
install -d -m755 "$pkgdir/usr/share/doc/mp3directcut"
install -m644 *.txt *.htm "$pkgdir/usr/share/doc/mp3directcut"
-
-} \ No newline at end of file
+}