summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--ffmpeg.patch13
3 files changed, 16 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e067cafe53f0..49809846beb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mpd-lightest
pkgdesc = "Lightest" mpd version with everything disabled. Modify PKGBUILD and enable the features and flags you need
pkgver = 0.21.7
- pkgrel = 2
+ pkgrel = 3
url = https://www.musicpd.org/
install = mpd.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 106d6fa05a7a..36cea152f8df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=mpd-lightest
pkgver=0.21.7
_majorver=0.21
-pkgrel=2
+pkgrel=3
pkgdesc='"Lightest" mpd version with everything disabled. Modify PKGBUILD and enable the features and flags you need'
url='https://www.musicpd.org/'
license=('GPL')
@@ -31,7 +31,7 @@ install=mpd.install
prepare() {
cd "${srcdir}/mpd-${pkgver}"
patch --input="${srcdir}/../meson.patch"
- patch -p0 -R --input="${srcdir}/../ffmpeg.patch"
+ patch -p2 --input="${srcdir}/../ffmpeg.patch"
install -d build
}
diff --git a/ffmpeg.patch b/ffmpeg.patch
new file mode 100644
index 000000000000..11c8e3263794
--- /dev/null
+++ b/ffmpeg.patch
@@ -0,0 +1,13 @@
+diff --git origin/mpd-0.21.7/src/input/plugins/FfmpegInputPlugin.cxx new/mpd-0.21.7/src/input/plugins/FfmpegInputPlugin.cxx
+index 198f4bd17..58686bf47 100644
+--- origin/mpd-0.21.7/src/input/plugins/FfmpegInputPlugin.cxx
++++ new/mpd-0.21.7/src/input/plugins/FfmpegInputPlugin.cxx
+@@ -118,6 +118,8 @@ static constexpr const char *ffmpeg_prefixes[] = {
+ "rtmp://",
+ "rtmpt://",
+ "rtmps://",
++ "http://",
++ "https://",
+ nullptr
+ };
+