summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO146
-rw-r--r--PKGBUILD110
-rw-r--r--mplayer.desktop22
-rw-r--r--mplayer.install11
-rw-r--r--mplayer.pngbin0 -> 1982 bytes
5 files changed, 289 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fda5e6c06140
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,146 @@
+pkgbase = mplayer
+ pkgver = 37551
+ pkgrel = 1
+ url = http://www.mplayerhq.hu/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libxxf86dga
+ makedepends = libxxf86vm
+ makedepends = libmad
+ makedepends = libxinerama
+ makedepends = sdl
+ makedepends = lame
+ makedepends = libtheora
+ makedepends = xvidcore
+ makedepends = libmng
+ makedepends = libxss
+ makedepends = libgl
+ makedepends = aalib
+ makedepends = jack
+ makedepends = libcaca
+ makedepends = faac
+ makedepends = faad2
+ makedepends = lirc
+ makedepends = libxvmc
+ makedepends = enca
+ makedepends = libvdpau
+ makedepends = opencore-amr
+ makedepends = libdca
+ makedepends = a52dec
+ makedepends = schroedinger
+ makedepends = libvpx
+ makedepends = libpulse
+ makedepends = fribidi
+ makedepends = unzip
+ makedepends = mesa
+ makedepends = live-media
+ makedepends = yasm
+ makedepends = git
+ makedepends = fontconfig
+ makedepends = mpg123
+ makedepends = ladspa
+ makedepends = libass
+ makedepends = libbluray
+ makedepends = libcdio-paranoia
+ makedepends = opus
+ makedepends = subversion
+ makedepends = x264
+ makedepends = libx264
+ makedepends = rtmpdump
+ makedepends = gnutls
+ makedepends = gsm
+ makedepends = libdvdcss
+ makedepends = libdvdread
+ makedepends = libdvdnav
+ options = !buildflags
+ options = !emptydirs
+ source = mplayer-37551::svn://svn.mplayerhq.hu/mplayer/trunk#revision=37551
+ source = http://ffmpeg.org/releases/ffmpeg-2.8.1.tar.bz2
+ source = mplayer.desktop
+ md5sums = SKIP
+ md5sums = 63b2cfeea930e942ff7579fd0064c5be
+ md5sums = 62f44a58f072b2b1a3c3d3e4976d64b3
+
+pkgname = mplayer-svn
+ pkgdesc = Media player for Linux
+ install = mplayer.install
+ depends = desktop-file-utils
+ depends = ttf-font
+ depends = enca
+ depends = libxss
+ depends = a52dec
+ depends = libvpx
+ depends = lirc
+ depends = libx264
+ depends = libmng
+ depends = libdca
+ depends = aalib
+ depends = lame
+ depends = fontconfig
+ depends = libgl
+ depends = libxinerama
+ depends = libvdpau
+ depends = libpulse
+ depends = xvidcore
+ depends = opencore-amr
+ depends = jack
+ depends = libmad
+ depends = sdl
+ depends = libtheora
+ depends = libcaca
+ depends = libxxf86dga
+ depends = fribidi
+ depends = libjpeg
+ depends = faac
+ depends = faad2
+ depends = libxvmc
+ depends = schroedinger
+ depends = mpg123
+ depends = libass
+ depends = libxxf86vm
+ depends = libbluray
+ depends = libcdio-paranoia
+ depends = opus
+ depends = rtmpdump
+ depends = gsm
+ depends = gnutls
+ depends = libdvdnav
+ conflicts = mplayer
+ backup = etc/mplayer/codecs.conf
+ backup = etc/mplayer/input.conf
+
+pkgname = mencoder-svn
+ pkgdesc = Free command line video decoding, encoding and filtering tool
+ depends = enca
+ depends = a52dec
+ depends = libvpx
+ depends = libx264
+ depends = libmng
+ depends = libdca
+ depends = bzip2
+ depends = lame
+ depends = alsa-lib
+ depends = fontconfig
+ depends = giflib
+ depends = libpng
+ depends = xvidcore
+ depends = opencore-amr
+ depends = libmad
+ depends = libtheora
+ depends = fribidi
+ depends = libjpeg
+ depends = faac
+ depends = faad2
+ depends = schroedinger
+ depends = mpg123
+ depends = libass
+ depends = libbluray
+ depends = libcdio-paranoia
+ depends = libvorbis
+ depends = opus
+ depends = rtmpdump
+ depends = gsm
+ depends = libdvdnav
+ conflicts = mencoder
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..736fb6090474
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,110 @@
+# Maintainer: Eric Toombs <e double u toombs at uwaterloo dot ca>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Hugo Doria <hugo@archlinux.org>
+
+pkgbase='mplayer-svn'
+pkgname=('mplayer-svn' 'mencoder-svn')
+pkgver=37551
+pkgrel=1
+_ffmpegver=2.8.1
+arch=('i686' 'x86_64')
+makedepends=(
+ 'libxxf86dga' 'libxxf86vm' 'libmad' 'libxinerama' 'sdl' 'lame' 'libtheora'
+ 'xvidcore' 'libmng' 'libxss' 'libgl' 'aalib' 'jack' 'libcaca'
+ 'faac' 'faad2' 'lirc' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr'
+ 'libdca' 'a52dec' 'schroedinger' 'libvpx' 'libpulse' 'fribidi' 'unzip' 'mesa'
+ 'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass' 'libbluray'
+ 'libcdio-paranoia' 'opus' 'subversion' 'x264' 'libx264' 'rtmpdump' 'gnutls'
+ 'gsm' 'libdvdcss' 'libdvdread' 'libdvdnav'
+)
+license=('GPL')
+url='http://www.mplayerhq.hu/'
+options=('!buildflags' '!emptydirs')
+source=("mplayer-$pkgver::svn://svn.mplayerhq.hu/mplayer/trunk#revision=$pkgver"
+ "http://ffmpeg.org/releases/ffmpeg-$_ffmpegver.tar.bz2"
+ 'mplayer.desktop')
+md5sums=('SKIP'
+ '63b2cfeea930e942ff7579fd0064c5be'
+ '62f44a58f072b2b1a3c3d3e4976d64b3')
+
+pkgver() {
+ cd "mplayer-$pkgver"
+ svnversion
+}
+
+prepare() {
+ cd "mplayer-$pkgver"
+ mv "../ffmpeg-$_ffmpegver" ffmpeg
+
+ ./version.sh
+}
+
+build() {
+ cd "mplayer-$pkgver"
+
+ ./configure --prefix=/usr \
+ --enable-runtime-cpudetection \
+ --disable-gui \
+ --disable-arts \
+ --disable-liblzo \
+ --disable-speex \
+ --disable-openal \
+ --disable-libdv \
+ --disable-musepack \
+ --disable-esd \
+ --disable-mga \
+ --disable-ass-internal \
+ --disable-cdparanoia \
+ --enable-xvmc \
+ --enable-radio \
+ --enable-radio-capture \
+ --language=all \
+ --confdir=/etc/mplayer
+ [[ "$CARCH" = "i686" ]] && sed 's|-march=i486|-march=i686|g' -i config.mak
+
+ make
+}
+
+package_mplayer-svn() {
+ pkgdesc='Media player for Linux'
+ install='mplayer.install'
+ backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
+ depends=(
+ 'desktop-file-utils' 'ttf-font' 'enca' 'libxss' 'a52dec' 'libvpx'
+ 'lirc' 'libx264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig'
+ 'libgl' 'libxinerama' 'libvdpau' 'libpulse' 'xvidcore'
+ 'opencore-amr' 'jack' 'libmad' 'sdl' 'libtheora' 'libcaca' 'libxxf86dga'
+ 'fribidi' 'libjpeg' 'faac' 'faad2' 'libxvmc' 'schroedinger' 'mpg123'
+ 'libass' 'libxxf86vm' 'libbluray' 'libcdio-paranoia' 'opus' 'rtmpdump'
+ 'gsm' 'gnutls' 'libdvdnav'
+ )
+ conflicts=('mplayer')
+
+ cd "mplayer-$pkgver"
+ make DESTDIR="$pkgdir" install-mplayer install-mplayer-man
+
+ install -Dm644 etc/{codecs.conf,input.conf,example.conf} \
+ "$pkgdir/etc/mplayer/"
+
+ # desktop file (FS#14770)
+ install -Dm644 ../mplayer.desktop \
+ "$pkgdir"/usr/share/applications/mplayer.desktop
+ install -Dm644 etc/mplayer256x256.png \
+ "$pkgdir"/usr/share/pixmaps/mplayer.png
+}
+
+package_mencoder-svn() {
+ pkgdesc='Free command line video decoding, encoding and filtering tool'
+ depends=(
+ 'enca' 'a52dec' 'libvpx' 'libx264' 'libmng' 'libdca' 'bzip2' 'lame'
+ 'alsa-lib' 'fontconfig' 'giflib' 'libpng' 'xvidcore'
+ 'opencore-amr' 'libmad' 'libtheora' 'fribidi' 'libjpeg' 'faac' 'faad2'
+ 'schroedinger' 'mpg123' 'libass' 'libbluray' 'libcdio-paranoia'
+ 'libvorbis' 'opus' 'rtmpdump' 'gsm' 'libdvdnav'
+ )
+ conflicts=('mencoder')
+
+ make -C mplayer-$pkgver DESTDIR="$pkgdir" install-mencoder install-mencoder-man
+ find "$pkgdir"/usr/share/man -name mplayer.1 -exec rename mplayer.1 mencoder.1 {} +
+}
diff --git a/mplayer.desktop b/mplayer.desktop
new file mode 100644
index 000000000000..946b8e345c22
--- /dev/null
+++ b/mplayer.desktop
@@ -0,0 +1,22 @@
+[Desktop Entry]
+Type=Application
+Name=MPlayer Media Player
+Name[ca]=Reproductor multimèdia MPlayer
+Name[pl]=MPlayer odtwarzacz multimedialny
+GenericName=Multimedia player
+Comment=Play movies and songs
+Comment[ca]=Reproduïu vídeos i cançons
+Comment[de]=Filme und Musik abspielen
+Comment[es]=Reproduzca vídeos y canciones
+Comment[fr]=Lecteur multimédia
+Comment[it]=Lettore multimediale
+Comment[zh]=多媒体播放器
+Comment[pl]=Odtwarzaj filmy i muzykę
+Icon=mplayer
+TryExec=mplayer
+Exec=mplayer %F
+Terminal=false
+NoDisplay=true
+Categories=GTK;AudioVideo;Audio;Video;Player;TV;
+MimeType=application/ogg;application/x-ogg;application/sdp;application/smil;application/x-smil;application/streamingmedia;application/x-streamingmedia;application/vnd.rn-realmedia;application/vnd.rn-realmedia-vbr;audio/aac;audio/x-aac;audio/m4a;audio/x-m4a;audio/mp1;audio/x-mp1;audio/mp2;audio/x-mp2;audio/mp3;audio/x-mp3;audio/mpeg;audio/x-mpeg;audio/mpegurl;audio/x-mpegurl;audio/mpg;audio/x-mpg;audio/rn-mpeg;audio/scpls;audio/x-scpls;audio/vnd.rn-realaudio;audio/wav;audio/x-pn-windows-pcm;audio/x-realaudio;audio/x-pn-realaudio;audio/x-ms-wma;audio/x-pls;audio/x-wav;video/mpeg;video/x-mpeg;video/x-mpeg2;video/mp4;video/msvideo;video/x-msvideo;video/quicktime;video/vnd.rn-realvideo;video/x-ms-afs;video/x-ms-asf;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvxvideo;video/x-avi;video/x-fli;video/x-flv;video/x-theora;video/x-matroska;
+X-KDE-Protocols=http,ftp,smb
diff --git a/mplayer.install b/mplayer.install
new file mode 100644
index 000000000000..660593cf5668
--- /dev/null
+++ b/mplayer.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/mplayer.png b/mplayer.png
new file mode 100644
index 000000000000..7997693350bb
--- /dev/null
+++ b/mplayer.png
Binary files differ