summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--unfuck_makefile.patch24
3 files changed, 37 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0ba949e3a0d..000441b2558f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 12 18:03:08 UTC 2018
+# Thu Apr 12 18:10:05 UTC 2018
pkgbase = mprime
pkgdesc = A GIMPS, distributed computing project client, dedicated to finding Mersenne primes.
pkgver = 294b7
- pkgrel = 3
+ pkgrel = 4
url = http://www.mersenne.org
arch = x86_64
license = custom
@@ -11,7 +11,9 @@ pkgbase = mprime
depends = hwloc
conflicts = mprime-bin
source = http://www.mersenne.org/ftp_root/gimps/p95v294b7.source.zip
+ source = unfuck_makefile.patch
sha256sums = 15682e9587af2b86647de9786f97dc8c5d7a4a679a0440f7d1d1936a48c5aa45
+ sha256sums = c94417f35f988e32693f9002792cbf21da85c2345670cb377066c9b799341528
pkgname = mprime
diff --git a/PKGBUILD b/PKGBUILD
index 320c11295179..0fae44fad609 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,21 @@
pkgname=mprime
pkgver=294b7
-pkgrel=3
+pkgrel=4
pkgdesc="A GIMPS, distributed computing project client, dedicated to finding Mersenne primes."
arch=('x86_64')
url="http://www.mersenne.org"
license=('custom')
depends=('curl' 'hwloc')
conflicts=('mprime-bin')
-source=("http://www.mersenne.org/ftp_root/gimps/p95v${pkgver}.source.zip")
-sha256sums=('15682e9587af2b86647de9786f97dc8c5d7a4a679a0440f7d1d1936a48c5aa45')
+source=("http://www.mersenne.org/ftp_root/gimps/p95v${pkgver}.source.zip"
+unfuck_makefile.patch)
+sha256sums=('15682e9587af2b86647de9786f97dc8c5d7a4a679a0440f7d1d1936a48c5aa45'
+ 'c94417f35f988e32693f9002792cbf21da85c2345670cb377066c9b799341528')
+
+prepare () {
+ patch -Np1 -i unfuck_makefile.patch
+}
build() {
cd "$srcdir/gwnum"
@@ -23,10 +29,6 @@ build() {
}
package() {
- CFLAGS="-I.. -I../gwnum -DX86_64 -march=x86-64 -O2 -Wno-unused-result"
- CXXFLAGS="$CFLAGS"
- LIBS="../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread $(pkg-config --libs libcurl) -lstdc++ $(pkg-config --static --libs hwloc) -lgmp"
-
install -Dm755 linux64/mprime "$pkgdir/usr/bin/mprime"
# license and documentation
diff --git a/unfuck_makefile.patch b/unfuck_makefile.patch
new file mode 100644
index 000000000000..c62a20827412
--- /dev/null
+++ b/unfuck_makefile.patch
@@ -0,0 +1,24 @@
+diff --git a/linux64/makefile b/linux64/makefile
+index 329cb51..88acbc6 100644
+--- a/linux64/makefile
++++ b/linux64/makefile
+@@ -20,15 +20,15 @@
+ # LFLAGS = -Wl,-M
+ # LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic $(shell pkg-config --static --libs libhwloc) -Wl,-Bstatic $(shell pkg-config --static --libs libcurl) -lstdc++ -Wl,-Bdynamic -ldl
+
++MPRIME_FLAGS=-I.. -I../gwnum -DX86_64 -march=x86-64 -O2 -Wno-unused-result
+ CC = gcc
+-CFLAGS = -I.. -I../gwnum -I/usr/local/include -DX86_64 -O2
++CFLAGS = ${MPRIME_FLAGS}
+
+ CPP = g++
+-CPPFLAGS = -I.. -I../gwnum -DX86_64 -O2
++CPPFLAGS = ${MPRIME_FLAGS}
+
+ LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
+-#LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
+-LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl -lgmp
++LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread $(shell pkg-config --libs libcurl) -lstdc++ $(shell pkg-config --static --libs hwloc) -lgmp
+
+ FACTOROBJ = factor64.o
+ LINUXOBJS = prime.o menu.o