summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
-rw-r--r--unfuck_makefile.patch12
3 files changed, 14 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90d9c53c9a2e..0223de37fe7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by mksrcinfo v8
-# Sat Apr 13 17:22:08 UTC 2019
pkgbase = mprime
pkgdesc = A GIMPS, distributed computing project client, dedicated to finding Mersenne primes.
- pkgver = 294b7
- pkgrel = 4
+ pkgver = 298b6
+ pkgrel = 1
url = http://www.mersenne.org
arch = x86_64
license = custom
depends = curl
depends = hwloc
conflicts = mprime-bin
- source = http://www.mersenne.org/ftp_root/gimps/p95v294b7.source.zip
+ source = http://www.mersenne.org/ftp_root/gimps/p95v298b6.source.zip
source = unfuck_makefile.patch
- sha256sums = 15682e9587af2b86647de9786f97dc8c5d7a4a679a0440f7d1d1936a48c5aa45
- sha256sums = c94417f35f988e32693f9002792cbf21da85c2345670cb377066c9b799341528
+ sha256sums = d96dbb88163a4b7acc993c4bd56dc9685ae8d3df73fbc0e6203d054d613be626
+ sha256sums = 48d7d5053429eea2e95848a5c4c9c7fa8dda71135affd4ac9612bbcdbe8a0350
pkgname = mprime
diff --git a/PKGBUILD b/PKGBUILD
index 0fae44fad609..40fc7967d51c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributer: TryA - https://bbs.archlinux.org/viewtopic.php?id=114996
pkgname=mprime
-pkgver=294b7
-pkgrel=4
+pkgver=298b6
+pkgrel=1
pkgdesc="A GIMPS, distributed computing project client, dedicated to finding Mersenne primes."
arch=('x86_64')
url="http://www.mersenne.org"
@@ -13,8 +13,8 @@ depends=('curl' 'hwloc')
conflicts=('mprime-bin')
source=("http://www.mersenne.org/ftp_root/gimps/p95v${pkgver}.source.zip"
unfuck_makefile.patch)
-sha256sums=('15682e9587af2b86647de9786f97dc8c5d7a4a679a0440f7d1d1936a48c5aa45'
- 'c94417f35f988e32693f9002792cbf21da85c2345670cb377066c9b799341528')
+sha256sums=('d96dbb88163a4b7acc993c4bd56dc9685ae8d3df73fbc0e6203d054d613be626'
+ '48d7d5053429eea2e95848a5c4c9c7fa8dda71135affd4ac9612bbcdbe8a0350')
prepare () {
patch -Np1 -i unfuck_makefile.patch
diff --git a/unfuck_makefile.patch b/unfuck_makefile.patch
index c62a20827412..904c9becd3ea 100644
--- a/unfuck_makefile.patch
+++ b/unfuck_makefile.patch
@@ -1,14 +1,12 @@
-diff --git a/linux64/makefile b/linux64/makefile
-index 329cb51..88acbc6 100644
---- a/linux64/makefile
-+++ b/linux64/makefile
-@@ -20,15 +20,15 @@
+--- a/linux64/makefile 2019-08-18 15:22:12.000000000 -0400
++++ b/linux64/makefile 2019-09-05 17:13:54.045672695 -0400
+@@ -20,15 +20,16 @@
# LFLAGS = -Wl,-M
# LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic $(shell pkg-config --static --libs libhwloc) -Wl,-Bstatic $(shell pkg-config --static --libs libcurl) -lstdc++ -Wl,-Bdynamic -ldl
+MPRIME_FLAGS=-I.. -I../gwnum -DX86_64 -march=x86-64 -O2 -Wno-unused-result
CC = gcc
--CFLAGS = -I.. -I../gwnum -I/usr/local/include -DX86_64 -O2
+-CFLAGS = -I.. -I../gwnum -I/usr/local/include -DX86_64 -Wno-unused-result -O2
+CFLAGS = ${MPRIME_FLAGS}
CPP = g++
@@ -16,7 +14,7 @@ index 329cb51..88acbc6 100644
+CPPFLAGS = ${MPRIME_FLAGS}
LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
--#LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
+ #LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
-LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl -lgmp
+LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread $(shell pkg-config --libs libcurl) -lstdc++ $(shell pkg-config --static --libs hwloc) -lgmp