summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--acestream.protocol11
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f535c450ce1..850f5993cfb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = mpv-acestream
pkgdesc = Lua script that adds AceStream protocol handler to mpv player
pkgver = 0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Digitalone1/mpv-acestream
install = mpv-acestream.install
arch = any
license = GPL3
optdepends = acestream-engine: AceStream engine
source = https://github.com/Digitalone1/mpv-acestream/archive/v0.1.tar.gz
+ source = acestream.protocol
md5sums = 14defb5825819786c86bf25a1a054cdc
+ md5sums = b3c9666c4e0aecd92f6fc208a2b3429e
pkgname = mpv-acestream
diff --git a/PKGBUILD b/PKGBUILD
index 4ff59da99e01..c2e10e05638e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mpv-acestream
pkgver=0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Lua script that adds AceStream protocol handler to mpv player"
arch=("any")
url="https://github.com/Digitalone1/mpv-acestream"
@@ -10,9 +10,13 @@ license=("GPL3")
#depends=()
#makedepends=()
optdepends=("acestream-engine: AceStream engine")
-source=("https://github.com/Digitalone1/mpv-acestream/archive/v$pkgver.tar.gz")
+source=(
+ "https://github.com/Digitalone1/mpv-acestream/archive/v$pkgver.tar.gz"
+ "acestream.protocol")
install="$pkgname.install"
-md5sums=("14defb5825819786c86bf25a1a054cdc")
+md5sums=(
+ "14defb5825819786c86bf25a1a054cdc"
+ "b3c9666c4e0aecd92f6fc208a2b3429e")
package() {
cd $pkgname-$pkgver
@@ -21,4 +25,7 @@ package() {
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 "README.md" "$pkgdir//usr/share/doc//$pkgname/README.md"
+
+ # Plasma 5 protocol file
+ install -Dm644 "$srcdir/acestream.protocol" "$pkgdir/usr/share/kservices5/acestream.protocol"
}
diff --git a/acestream.protocol b/acestream.protocol
new file mode 100644
index 000000000000..ee8796d867d2
--- /dev/null
+++ b/acestream.protocol
@@ -0,0 +1,11 @@
+[Protocol]
+exec=/usr/bin/mpv %u
+protocol=acestream
+input=none
+output=none
+helper=true
+listing=false
+reading=false
+writing=false
+makedir=false
+deleting=false