summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0177bc692ba..c5ec72088771 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = mpz-qt6
pkgdesc = Music player for the large local collections
pkgver = 1.0.19
- pkgrel = 24
+ pkgrel = 38
url = https://github.com/olegantonyan/mpz
arch = x86_64
license = GPL3
depends = qt6-multimedia
depends = hicolor-icon-theme
+ depends = yaml-cpp
+ depends = taglib
provides = mpz
conflicts = mpz
- source = mpz-qt6-1.0.19-24.zip::https://github.com/olegantonyan/mpz/archive/3c0daf7457ff9e69a6230881f25c5b0cb1aceef5.zip
- sha256sums = cb856236972e5a7ea6b971defa84b8e824f840aec838cb516253d7e9690311a7
+ source = mpz-qt6-1.0.19-38.zip::https://github.com/olegantonyan/mpz/archive/b8090ba6c92bdc866b391a3b1fa72a05bba63a06.zip
+ sha256sums = 7ae22d3d53348d53a64d6d6d583da787d3d34e929b9e6c551fb2ed4abc53f30b
pkgname = mpz-qt6
diff --git a/PKGBUILD b/PKGBUILD
index 707339fbe915..441f477efd0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,29 @@
pkgname=mpz-qt6
pkgver=1.0.19
-pkgrel=24
+pkgrel=38
pkgdesc='Music player for the large local collections (Qt6 version)'
arch=('x86_64')
url="https://github.com/olegantonyan/mpz"
license=('GPL3')
-depends=('qt6-multimedia' 'hicolor-icon-theme')
+depends=('qt6-multimedia' 'hicolor-icon-theme' 'yaml-cpp' 'taglib')
provides=('mpz')
conflicts=('mpz')
-source=("$pkgname-$pkgver-$pkgrel.zip::https://github.com/olegantonyan/mpz/archive/3c0daf7457ff9e69a6230881f25c5b0cb1aceef5.zip")
-sha256sums=('cb856236972e5a7ea6b971defa84b8e824f840aec838cb516253d7e9690311a7')
+source=("$pkgname-$pkgver-$pkgrel.zip::https://github.com/olegantonyan/mpz/archive/b8090ba6c92bdc866b391a3b1fa72a05bba63a06.zip")
+sha256sums=('7ae22d3d53348d53a64d6d6d583da787d3d34e929b9e6c551fb2ed4abc53f30b')
build() {
- cd mpz-3c0daf7457ff9e69a6230881f25c5b0cb1aceef5
+ cd mpz-b8090ba6c92bdc866b391a3b1fa72a05bba63a06
rm -rf build
mkdir build
cd build
- qmake6 CONFIG+=release ..
+ qmake6 CONFIG+=release DEFINES+=USE_SYSTEM_TAGLIB DEFINES+=USE_SYSTEM_YAMLCPP ..
make
}
package() {
- cd mpz-3c0daf7457ff9e69a6230881f25c5b0cb1aceef5
+ cd mpz-b8090ba6c92bdc866b391a3b1fa72a05bba63a06
cd build
make install INSTALL_ROOT=$pkgdir