summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
-rw-r--r--remove_termcap_static_lib.patch17
3 files changed, 11 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7b8a0273929..51deaf50dc66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mruby
pkgdesc = Lightweight Ruby
- pkgver = 1.1.0
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/mruby/mruby
arch = i686
@@ -9,11 +9,10 @@ pkgbase = mruby
makedepends = git
makedepends = bison
makedepends = ruby
+ depends = readline
options = staticlibs
- source = https://github.com/mruby/mruby/archive/1.1.0.zip
- source = remove_termcap_static_lib.patch
- sha1sums = SKIP
- sha1sums = 3042fc7811afee7e88535dca43495a1a5486d6a5
+ source = mruby-1.2.0.zip::https://github.com/mruby/mruby/archive/1.2.0.zip
+ sha1sums = 0f3c535d6c89b710d1fd0fdbf167077abce55996
pkgname = mruby
diff --git a/PKGBUILD b/PKGBUILD
index 6c779d13f2c9..2f48aa29ad57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,17 @@
# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
pkgname=mruby
-pkgver=1.1.0
+pkgver=1.2.0
pkgrel=1
pkgdesc='Lightweight Ruby'
arch=(i686 x86_64)
url='https://github.com/mruby/mruby'
license=(MIT)
+depends=(readline)
makedepends=(git bison ruby)
options=(staticlibs)
-source=(https://github.com/mruby/mruby/archive/$pkgver.zip
- remove_termcap_static_lib.patch)
-sha1sums=('SKIP'
- '3042fc7811afee7e88535dca43495a1a5486d6a5')
-
-prepare() {
- cd mruby-$pkgver
- patch -p1 < "$srcdir"/remove_termcap_static_lib.patch
-}
+source=(mruby-$pkgver.zip::https://github.com/mruby/mruby/archive/$pkgver.zip)
+sha1sums=('0f3c535d6c89b710d1fd0fdbf167077abce55996')
build() {
cd mruby-$pkgver
@@ -33,9 +27,11 @@ check() {
package() {
cd mruby-$pkgver
- install -d "$pkgdir/usr/bin" "$pkgdir/usr/lib"
+ install -d "$pkgdir/usr/bin" "$pkgdir/usr/lib" "$pkgdir/usr/share/licenses/mruby"
cp build/host/bin/* "$pkgdir/usr/bin"
cp build/host/lib/*.a "$pkgdir/usr/lib"
cp -r include "$pkgdir/usr"
+
+ cp MITL "$pkgdir/usr/share/licenses/mruby/LICENSE"
}
diff --git a/remove_termcap_static_lib.patch b/remove_termcap_static_lib.patch
deleted file mode 100644
index 5ac108033b25..000000000000
--- a/remove_termcap_static_lib.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/mrbgems/mruby-bin-mirb/mrbgem.rake b/mrbgems/mruby-bin-mirb/mrbgem.rake
-index 6ddd972..fa0499f 100644
---- a/mrbgems/mruby-bin-mirb/mrbgem.rake
-+++ b/mrbgems/mruby-bin-mirb/mrbgem.rake
-@@ -6,11 +6,7 @@ MRuby::Gem::Specification.new('mruby-bin-mirb') do |spec|
- if spec.build.cc.search_header_path 'readline/readline.h'
- spec.cc.defines << "ENABLE_READLINE"
- if spec.build.cc.search_header_path 'termcap.h'
-- if MRUBY_BUILD_HOST_IS_CYGWIN then
-- spec.linker.libraries << 'ncurses'
-- else
-- spec.linker.libraries << 'termcap'
-- end
-+ spec.linker.libraries << 'ncurses'
- end
- spec.linker.libraries << 'readline'
- elsif spec.build.cc.search_header_path 'linenoise.h'