summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD32
2 files changed, 29 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da126ef245a9..6c4e83518b6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = msbuild
- pkgdesc = Xamarin implementation of the Microsoft build system
pkgver = 16.0+xamarinxplat.2019.04.08.19.19
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/mono/msbuild
arch = x86_64
license = MIT
makedepends = libcurl-gnutls
- depends = mono>=5.0.0
- provides = msbuild
- conflicts = msbuild
source = https://download.mono-project.com/sources/msbuild/msbuild-16.0+xamarinxplat.2019.04.08.19.19.tar.xz
source = fix-install.patch
sha256sums = 0d425603281ae84d3cf560ea4f9e2b2159e7764f71406035070a7fe27878ec49
sha256sums = 8780925e01d4e5bdf8f93c439fe92da7a64f14099b60382499b477a512b56dca
pkgname = msbuild
+ pkgdesc = Xamarin implementation of the Microsoft build system
+ depends = mono>=5.0.0
+
+pkgname = msbuild-sdkresolver
+ pkgdesc = Xamarin implementation of the Microsoft build system (SDK resolver)
+ depends = msbuild
diff --git a/PKGBUILD b/PKGBUILD
index 62087cd7e6e8..f97dfcdd21bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,11 @@
# Maintainer: Florian Maunier <fmauneko@dissidence.ovh>
# Contributor: jtmb <packaging at technologicalwizardry dot com>
-pkgname=msbuild
+pkgbase=msbuild
+pkgname=('msbuild' 'msbuild-sdkresolver')
pkgver=16.0+xamarinxplat.2019.04.08.19.19
-pkgrel=2
-pkgdesc="Xamarin implementation of the Microsoft build system"
+pkgrel=3
arch=('x86_64')
-depends=('mono>=5.0.0')
makedepends=('libcurl-gnutls')
-provides=('msbuild')
-conflicts=('msbuild')
url="https://github.com/mono/msbuild"
license=('MIT')
source=("https://download.mono-project.com/sources/msbuild/msbuild-${pkgver}.tar.xz"
@@ -21,11 +18,26 @@ prepare() {
patch --forward --strip=1 --input="${srcdir}/fix-install.patch"
}
-package() {
+build() {
cd "${pkgname}-${pkgver%+*}"
make
- ./install-mono-prefix.sh "/usr" /p:StagingDir="${pkgdir}/usr" /p:TargetMSBuildToolsVersion="15.0"
- find $pkgdir/usr/lib/mono/ -name Microsoft.DiaSymReader.Native.*dll -delete
- find $pkgdir/usr/lib/mono/ -name *.dylib -delete
+ ./install-mono-prefix.sh "/usr" /p:StagingDir="${srcdir}/target/usr" /p:TargetMSBuildToolsVersion="15.0"
+ find $srcdir/target/usr/lib/mono/ -name Microsoft.DiaSymReader.Native.*dll -delete
+ find $srcdir/target/usr/lib/mono/ -name *.dylib -delete
+}
+
+package_msbuild() {
+ pkgdesc="Xamarin implementation of the Microsoft build system"
+ depends=('mono>=5.0.0')
+
+ cp -dr --no-preserve='ownership' $srcdir/target/usr "${pkgdir}"
rm -rf $pkgdir/usr/lib/mono/msbuild/15.0/bin/SdkResolvers/Microsoft.DotNet.MSBuildSdkResolver
}
+
+package_msbuild-sdkresolver() {
+ pkgdesc="Xamarin implementation of the Microsoft build system (SDK resolver)"
+ depends=('msbuild')
+
+ mkdir -p "${pkgdir}"/usr/lib/mono/msbuild/15.0/bin/SdkResolvers/
+ cp -dr --no-preserve='ownership' $srcdir/target/usr/lib/mono/msbuild/15.0/bin/SdkResolvers/Microsoft.DotNet.MSBuildSdkResolver "${pkgdir}"/usr/lib/mono/msbuild/15.0/bin/SdkResolvers/
+}