summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
-rw-r--r--copy_hostfxr.patch12
-rw-r--r--fix_bashisms.patch42
-rw-r--r--fixed-build-version.patch40
-rw-r--r--license_check_is_case_sensitive.diff (renamed from license-check-is-case-sensitive.patch)0
6 files changed, 83 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index accf22b88019..01788f197b44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = msbuild
- pkgver = 16.1+xamarinxplat.2019.06.05.11.19
- pkgrel = 6
+ pkgver = 16.3+xamarinxplat.2019.08.08.00.55
+ pkgrel = 1
url = https://github.com/mono/msbuild
arch = x86_64
license = MIT
makedepends = unzip
- source = https://download.mono-project.com/sources/msbuild/msbuild-16.1+xamarinxplat.2019.06.05.11.19.tar.xz
- source = fixed-build-version.patch
- source = license-check-is-case-sensitive.patch
- sha256sums = 8184b32f446aba5634342148c0d87a84073ee2ce160e325ae3a04d6b368b45e1
- sha256sums = 4acf88ec981bc687be8eb2aa7c000db21e6fb98fa68727c21cb6db3395f4b4df
+ makedepends = dotnet-host
+ depends = mono>=6.0.0
+ source = https://download.mono-project.com/sources/msbuild/msbuild-16.3+xamarinxplat.2019.08.08.00.55.tar.xz
+ source = copy_hostfxr.patch
+ source = fix_bashisms.patch
+ source = license_check_is_case_sensitive.diff
+ sha256sums = 2bd5ee0617754a87a311581d62325eda43c0d0b312fe614f60a57e54dc6155a2
+ sha256sums = f08615c058771fe740758d9bd2e23e01a52c5d51fab05a15558622e7f7974f22
+ sha256sums = a13ecb4125c673372d87a3b7d957fc8716a3c3e74cd08e9e354b5dcf170ed453
sha256sums = 3a12a9c33ad5938e8af24d2985241053602f4efc94a4818a00a17da32ce4aba5
pkgname = msbuild
pkgdesc = Xamarin implementation of the Microsoft build system
- depends = mono>=6.0.0
pkgname = msbuild-sdkresolver
pkgdesc = Xamarin implementation of the Microsoft build system (SDK resolver)
diff --git a/PKGBUILD b/PKGBUILD
index b2d6960e2e5e..6c2f58e5e982 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,42 @@
# Contributor: jtmb <packaging at technologicalwizardry dot com>
pkgbase=msbuild
pkgname=('msbuild' 'msbuild-sdkresolver')
-pkgver=16.1+xamarinxplat.2019.06.05.11.19
-pkgrel=6
+pkgver=16.3+xamarinxplat.2019.08.08.00.55
+pkgrel=1
arch=('x86_64')
url="https://github.com/mono/msbuild"
license=('MIT')
-makedepends=('unzip')
+depends=('mono>=6.0.0')
+makedepends=('unzip' 'dotnet-host' 'dotnet-sdk')
source=("https://download.mono-project.com/sources/msbuild/msbuild-${pkgver}.tar.xz"
- 'fixed-build-version.patch'
- 'license-check-is-case-sensitive.patch')
-sha256sums=('8184b32f446aba5634342148c0d87a84073ee2ce160e325ae3a04d6b368b45e1'
- '4acf88ec981bc687be8eb2aa7c000db21e6fb98fa68727c21cb6db3395f4b4df'
+ 'copy_hostfxr.patch'
+ 'fix_bashisms.patch'
+ 'license_check_is_case_sensitive.diff')
+sha256sums=('2bd5ee0617754a87a311581d62325eda43c0d0b312fe614f60a57e54dc6155a2'
+ 'f08615c058771fe740758d9bd2e23e01a52c5d51fab05a15558622e7f7974f22'
+ 'a13ecb4125c673372d87a3b7d957fc8716a3c3e74cd08e9e354b5dcf170ed453'
'3a12a9c33ad5938e8af24d2985241053602f4efc94a4818a00a17da32ce4aba5')
prepare() {
cd "${pkgname}-${pkgver%+*}"
- patch --forward --strip=1 --input="${srcdir}/fixed-build-version.patch"
- patch --forward --strip=1 --input="${srcdir}/license-check-is-case-sensitive.patch"
+ patch --forward --strip=1 --input="${srcdir}/fix_bashisms.patch"
+ patch --forward --strip=1 --input="${srcdir}/copy_hostfxr.patch"
+ patch --forward --strip=1 --input="${srcdir}/license_check_is_case_sensitive.diff"
+ cp $(pacman -Ql dotnet-host | grep libhostfxr.so | cut -d' ' -f2) ./mono/SdkResolvers/Microsoft.DotNet.MSBuildSdkResolver/
}
build() {
cd "${pkgname}-${pkgver%+*}"
- ./eng/cibuild_bootstrapped_msbuild.sh --host_type mono --configuration Release --skip_tests /p:DisableNerdbankVersioning=true
- ./artifacts/mono-msbuild/msbuild mono/build/install.proj /p:MonoInstallPrefix=$srcdir/target/usr /p:Configuration=Release-MONO /p:IgnoreDiffFailure=true
+ DOTNET_MSBUILD_SDK_RESOLVER_CLI_DIR=/opt/dotnet ./eng/cibuild_bootstrapped_msbuild.sh --host_type mono --configuration Release --skip_tests /p:DisableNerdbankVersioning=true
+ ./stage1/mono-msbuild/msbuild mono/build/install.proj /p:MonoInstallPrefix=$srcdir/target/usr /p:Configuration=Release-MONO /p:IgnoreDiffFailure=true
sed -i "s@${srcdir}/target@@g" $srcdir/target/usr/bin/msbuild
find $srcdir/target/usr/lib/mono/ -name Microsoft.DiaSymReader.Native.*dll -delete
find $srcdir/target/usr/lib/mono/ -name *.dylib -delete
+ find $srcdir/target/usr/lib/mono/ -name *.so -delete
}
package_msbuild() {
pkgdesc="Xamarin implementation of the Microsoft build system"
- depends=('mono>=6.0.0')
cp -dr --no-preserve='ownership' $srcdir/target/usr "${pkgdir}"
rm -rf $pkgdir/usr/lib/mono/msbuild/Current/bin/SdkResolvers/Microsoft.DotNet.MSBuildSdkResolver
@@ -40,10 +45,9 @@ package_msbuild() {
package_msbuild-sdkresolver() {
pkgdesc="Xamarin implementation of the Microsoft build system (SDK resolver)"
- makedepends=('dotnet-host')
depends=('msbuild')
mkdir -p "${pkgdir}"/usr/lib/mono/msbuild/Current/bin/SdkResolvers/
cp -dr --no-preserve='ownership' $srcdir/target/usr/lib/mono/msbuild/Current/bin/SdkResolvers/Microsoft.DotNet.MSBuildSdkResolver "${pkgdir}"/usr/lib/mono/msbuild/Current/bin/SdkResolvers/
- cp -dr --no-preserve='ownership' $(pacman -Ql dotnet-host | grep libhostfxr.so | cut -d' ' -f2) "${pkgdir}"/usr/lib/mono/msbuild/Current/bin/SdkResolvers/Microsoft.DotNet.MSBuildSdkResolver/
+ #cp -dr --no-preserve='ownership' $(pacman -Ql dotnet-host | grep libhostfxr.so | cut -d' ' -f2) "${pkgdir}"/usr/lib/mono/msbuild/Current/bin/SdkResolvers/Microsoft.DotNet.MSBuildSdkResolver/
}
diff --git a/copy_hostfxr.patch b/copy_hostfxr.patch
new file mode 100644
index 000000000000..58348b9cf3c5
--- /dev/null
+++ b/copy_hostfxr.patch
@@ -0,0 +1,12 @@
+Index: xamarin-pkg-msbuild/eng/cibuild_bootstrapped_msbuild.sh
+===================================================================
+--- xamarin-pkg-msbuild.orig/eng/cibuild_bootstrapped_msbuild.sh
++++ xamarin-pkg-msbuild/eng/cibuild_bootstrapped_msbuild.sh
+@@ -56,6 +56,7 @@ function DownloadMSBuildForMono {
+ unzip -q "$msbuild_zip" -d "$artifacts_dir"
+ # rename just to make it obvious when reading logs!
+ mv $artifacts_dir/msbuild $mono_msbuild_dir
++ cp $(pacman -Ql dotnet-host | grep libhostfxr.so | cut -d' ' -f2) $artifacts_dir/mono-msbuild/SdkResolvers/Microsoft.DotNet.MSBuildSdkResolver/
+ sed -i 's#/sh$#/bash#' $artifacts_dir/mono-msbuild/msbuild
+ chmod +x $artifacts_dir/mono-msbuild/MSBuild.dll
+ rm "$msbuild_zip"
diff --git a/fix_bashisms.patch b/fix_bashisms.patch
new file mode 100644
index 000000000000..7125ca50ac3f
--- /dev/null
+++ b/fix_bashisms.patch
@@ -0,0 +1,42 @@
+Index: xamarin-pkg-msbuild/gen_build_info.sh
+===================================================================
+--- xamarin-pkg-msbuild.orig/gen_build_info.sh
++++ xamarin-pkg-msbuild/gen_build_info.sh
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+
+ if [ $# -ne 1 ]; then
+ echo "Usage: $0 <filename.cs>"
+Index: xamarin-pkg-msbuild/mono/create_bootstrap.sh
+===================================================================
+--- xamarin-pkg-msbuild.orig/mono/create_bootstrap.sh
++++ xamarin-pkg-msbuild/mono/create_bootstrap.sh
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+
+ # This creates a bootstrap from an exising mono installation
+ # This is just to ensure that we have the correct "matched" Roslyn
+Index: xamarin-pkg-msbuild/msbuild-deploy.in
+===================================================================
+--- xamarin-pkg-msbuild.orig/msbuild-deploy.in
++++ xamarin-pkg-msbuild/msbuild-deploy.in
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+ ABSOLUTE_PATH=$(cd `dirname "${BASH_SOURCE[0]}"` && pwd)/`basename "${BASH_SOURCE[0]}"`
+ MSBUILD_SRC_DIR=`dirname $ABSOLUTE_PATH`
+ mono $MONO_OPTIONS $MSBUILD_SRC_DIR/MSBuild.exe $*
+Index: xamarin-pkg-msbuild/eng/cibuild_bootstrapped_msbuild.sh
+===================================================================
+--- xamarin-pkg-msbuild.orig/eng/cibuild_bootstrapped_msbuild.sh
++++ xamarin-pkg-msbuild/eng/cibuild_bootstrapped_msbuild.sh
+@@ -56,6 +56,7 @@ function DownloadMSBuildForMono {
+ unzip -q "$msbuild_zip" -d "$artifacts_dir"
+ # rename just to make it obvious when reading logs!
+ mv $artifacts_dir/msbuild $mono_msbuild_dir
++ sed -i 's#/sh$#/bash#' $artifacts_dir/mono-msbuild/msbuild
+ chmod +x $artifacts_dir/mono-msbuild/MSBuild.dll
+ rm "$msbuild_zip"
+ fi
diff --git a/fixed-build-version.patch b/fixed-build-version.patch
deleted file mode 100644
index 1923db26f0fd..000000000000
--- a/fixed-build-version.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Index: xamarin-pkg-msbuild/src/Build.OM.UnitTests/Definition/ProjectCollection_Tests.cs
-===================================================================
---- xamarin-pkg-msbuild.orig/src/Build.OM.UnitTests/Definition/ProjectCollection_Tests.cs
-+++ xamarin-pkg-msbuild/src/Build.OM.UnitTests/Definition/ProjectCollection_Tests.cs
-@@ -1422,10 +1422,14 @@ namespace Microsoft.Build.UnitTests.OM.D
- [Fact]
- public void ProjectCollectionVersionIsCorrect()
- {
-+ ProjectCollection.Version.ShouldNotBe(new Version(0, 0, 0, 0));
-+
-+#if THISASSEMBLY
- Version expectedVersion = new Version(ThisAssembly.AssemblyFileVersion);
-
- ProjectCollection.Version.Major.ShouldBe(expectedVersion.Major);
- ProjectCollection.Version.Minor.ShouldBe(expectedVersion.Minor);
-+#endif
- }
-
- /// <summary>
-Index: xamarin-pkg-msbuild/src/Directory.Build.targets
-===================================================================
---- xamarin-pkg-msbuild.orig/src/Directory.Build.targets
-+++ xamarin-pkg-msbuild/src/Directory.Build.targets
-@@ -107,6 +107,16 @@
-
- <Import Project="$([System.IO.Path]::Combine('$(RepoRoot)', 'eng', 'GetBuildVersionStub.proj'))" Condition="'$(DisableNerdbankVersioning)' == 'true'" />
-
-+ <Target Name="OverrideRepoToolsetVersions"
-+ AfterTargets="_InitializeAssemblyVersion"
-+ Condition="'$(DisableNerdbankVersioning)' == 'true'">
-+ <PropertyGroup>
-+ <AssemblyVersion>15.1.0.0</AssemblyVersion>
-+ <FileVersion>16.0.0.0</FileVersion>
-+ <InformationalVersion>$(FileVersion)-mono</InformationalVersion>
-+ </PropertyGroup>
-+ </Target>
-+
- <Target Name="GetNuGetPackageVersionEx"
- BeforeTargets="GenerateNuspec"
- DependsOnTargets="GetBuildVersion"
diff --git a/license-check-is-case-sensitive.patch b/license_check_is_case_sensitive.diff
index a590dcb78ff3..a590dcb78ff3 100644
--- a/license-check-is-case-sensitive.patch
+++ b/license_check_is_case_sensitive.diff