summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD45
-rw-r--r--mshv.desktop9
-rw-r--r--mshv_launcher.sh19
4 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb82e25aeba5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = mshv
+ pkgdesc = Amateur radio software by LZ2HV for digital modes MSK, JTMS, FSK, ISCAT, JT6M, FT8/4, JT65, PI4, Q65.
+ pkgver = 258
+ pkgrel = 1
+ url = http://lz2hv.org/mshv
+ arch = any
+ license = GPL3
+ depends = fftw
+ depends = alsa-lib
+ depends = libpulse
+ depends = qt5-base
+ depends = qt5-websockets
+ depends = hamradio-menus
+ provides = mshv
+ conflicts = mshv
+ source = https://downloads.sourceforge.net/project/mshv/MSHV_258_Full_Source_Code.zip
+ source = mshv_launcher.sh
+ source = mshv.desktop
+ sha256sums = 039c4d432010fdae0805a023960145038c6ae780f7c439d77514aff6cf80cf1d
+ sha256sums = 5ccd21e3d585efb4f37aff8a3470aefa78a8689dad3b00334b9a8467840adbab
+ sha256sums = 85c256463746cb8a06ff1eee71677dcbe1d1c54d7aaf0f27156ebe9632269dba
+
+pkgname = mshv
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea93bf53a1cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Erik Bročko <erik.brocko@letemsvetemapplem.eu>
+
+pkgname=mshv
+pkgver=258
+pkgrel=1
+pkgdesc="Amateur radio software by LZ2HV for digital modes MSK, JTMS, FSK, ISCAT, JT6M, FT8/4, JT65, PI4, Q65."
+arch=('any')
+url="http://lz2hv.org/mshv"
+license=('GPL3')
+depends=('fftw' 'alsa-lib' 'libpulse' 'qt5-base' 'qt5-websockets' 'hamradio-menus')
+makedepends=()
+conflicts=('mshv')
+provides=('mshv')
+source=(
+ "https://downloads.sourceforge.net/project/mshv/MSHV_${pkgver}_Full_Source_Code.zip"
+ "mshv_launcher.sh"
+ "mshv.desktop"
+)
+sha256sums=(
+ '039c4d432010fdae0805a023960145038c6ae780f7c439d77514aff6cf80cf1d'
+ '5ccd21e3d585efb4f37aff8a3470aefa78a8689dad3b00334b9a8467840adbab'
+ '85c256463746cb8a06ff1eee71677dcbe1d1c54d7aaf0f27156ebe9632269dba'
+)
+
+build() {
+ cd "$srcdir/MSHV_$pkgver"
+
+ # There doesn't seem to be any difference between the .pro files apart from absolute paths
+ # passed to the linker for some libraries. We'll just rely on ld to find the libraries.
+ qmake MSHV_x86_64.pro PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"
+ install -D -m755 mshv_launcher.sh "$pkgdir/usr/bin/mshv"
+
+ cd "$srcdir/MSHV_$pkgver/bin"
+ install -D -m755 MSHV_x86_64 "$pkgdir/usr/bin/mshv_bin"
+
+ find . -type d -exec install -d -m755 "$pkgdir/usr/share/mshv/"{} \;
+ find . ! -name 'MSHV_x86_64' -type f -exec install -D -m644 {} "$pkgdir/usr/share/mshv/"{} \;
+
+ install -D -m644 settings/resources/ms_ico.png "$pkgdir/usr/share/pixmaps/mshv.png"
+}
diff --git a/mshv.desktop b/mshv.desktop
new file mode 100644
index 000000000000..7232f8e1c469
--- /dev/null
+++ b/mshv.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=MSHV
+GenericName=Ham radio software for digital modes
+Comment=Amateur radio software by LZ2HV for modes MSK, JTMS, FSK, ISCAT, JT6M, FT8/4, JT65, PI4, Q65.
+Exec=mshv
+Icon=mshv
+Terminal=false
+Type=Application
+Categories=HamRadio;
diff --git a/mshv_launcher.sh b/mshv_launcher.sh
new file mode 100644
index 000000000000..e07a2b576832
--- /dev/null
+++ b/mshv_launcher.sh
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+# This is a launcher script provided by the `mshv` package.
+# Copying the files is necessary, because MSHV can only work
+# with configs and files in the same directory as the executable.
+
+pkgname="mshv"
+WORKDIR="${WORKDIR:-"$HOME/.local/share/$pkgname"}"
+
+if [ ! -d "$WORKDIR" ]; then
+ cp -r "/usr/share/$pkgname" "$WORKDIR"
+fi
+
+# There was an update.
+if ! cmp -s "/usr/bin/${pkgname}_bin" "$WORKDIR/mshv"; then
+ cp "/usr/bin/${pkgname}_bin" "$WORKDIR/mshv"
+fi
+
+"$WORKDIR/mshv" "$@"