summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--flrigxml.patch12
-rw-r--r--pa_with_no_alsa.patch12
4 files changed, 32 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dd6d531c3ac..b681b23779ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mshv
pkgdesc = Amateur radio software by LZ2HV for digital modes MSK, JTMS, FSK, ISCAT, JT6M, FT8/4, JT65, PI4, Q65.
- pkgver = 258
- pkgrel = 4
+ pkgver = 262
+ pkgrel = 1
url = http://lz2hv.org/mshv
arch = any
license = GPL3
@@ -13,15 +13,14 @@ pkgbase = mshv
depends = hamradio-menus
provides = mshv
conflicts = mshv
- source = https://downloads.sourceforge.net/project/mshv/MSHV_258_Full_Source_Code.zip
+ source = https://downloads.sourceforge.net/project/mshv/MSHV_262_Full_Source_Code.zip
source = mshv_launcher.sh
source = mshv.desktop
- source = flrigxml.patch
- source = pa_with_no_alsa.patch
- sha256sums = 039c4d432010fdae0805a023960145038c6ae780f7c439d77514aff6cf80cf1d
+ md5sums = 097e7ca3b48a1a28e5c686780106a2e3
+ md5sums = SKIP
+ md5sums = SKIP
+ sha256sums = SKIP
sha256sums = 5ccd21e3d585efb4f37aff8a3470aefa78a8689dad3b00334b9a8467840adbab
sha256sums = 85c256463746cb8a06ff1eee71677dcbe1d1c54d7aaf0f27156ebe9632269dba
- sha256sums = 22de199636d17912738651eba8db6b5ccf7cecae816dcddee6d46a33d585f8ca
- sha256sums = 6d021299b6970e262f73749e2e3b4c859cb5a0f36e19dfd44a0a6924dcc0d7d9
pkgname = mshv
diff --git a/PKGBUILD b/PKGBUILD
index ec07f6dd8fde..34808381c0af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Erik Bročko <erik.brocko@letemsvetemapplem.eu>
pkgname=mshv
-pkgver=258
-pkgrel=4
+pkgver=262
+pkgrel=1
pkgdesc="Amateur radio software by LZ2HV for digital modes MSK, JTMS, FSK, ISCAT, JT6M, FT8/4, JT65, PI4, Q65."
arch=('any')
url="http://lz2hv.org/mshv"
@@ -11,28 +11,40 @@ depends=('fftw' 'alsa-lib' 'libpulse' 'qt5-base' 'qt5-websockets' 'hamradio-menu
makedepends=()
conflicts=('mshv')
provides=('mshv')
+
+# This is suboptimal. But pkgver doesn't seem to get updated soon enough to allow sources to properly download.
+_sfrss="$(curl -s -L "https://sourceforge.net/projects/mshv/rss?path=/")"
+_latestver="$(echo "$_sfrss" | \
+ grep -Poi ' url="https://sourceforge.net/projects/mshv/files/MSHV_\K(\d+)_Full_Source_Code\.zip/download" filesize="\d+"><media:hash algo="md5">([a-fA-F\d]{32})</media:hash></media:content>'\
+ | head -n1 \
+ | cut -d '_' -f 1)"
+_latesthash="$(echo "$_sfrss" | \
+ grep -Poi ' url="https://sourceforge.net/projects/mshv/files/MSHV_(\d+)_Full_Source_Code\.zip/download" filesize="\d+"><media:hash algo="md5">\K([a-fA-F\d]{32})</media:hash></media:content>'\
+ | head -n1 \
+ | cut -d '<' -f 1)"
+
source=(
- "https://downloads.sourceforge.net/project/mshv/MSHV_${pkgver}_Full_Source_Code.zip"
+ "https://downloads.sourceforge.net/project/mshv/MSHV_${_latestver}_Full_Source_Code.zip"
"mshv_launcher.sh"
"mshv.desktop"
- "flrigxml.patch"
- "pa_with_no_alsa.patch"
)
sha256sums=(
- '039c4d432010fdae0805a023960145038c6ae780f7c439d77514aff6cf80cf1d'
+ 'SKIP'
'5ccd21e3d585efb4f37aff8a3470aefa78a8689dad3b00334b9a8467840adbab'
'85c256463746cb8a06ff1eee71677dcbe1d1c54d7aaf0f27156ebe9632269dba'
- '22de199636d17912738651eba8db6b5ccf7cecae816dcddee6d46a33d585f8ca'
- '6d021299b6970e262f73749e2e3b4c859cb5a0f36e19dfd44a0a6924dcc0d7d9'
+)
+md5sums=(
+ "$_latesthash"
+ 'SKIP'
+ 'SKIP'
)
-prepare() {
- patch --directory="$srcdir/MSHV_$pkgver" --forward --strip=1 --input="$srcdir/flrigxml.patch"
- patch --directory="$srcdir/MSHV_$pkgver" --forward --strip=1 --input="$srcdir/pa_with_no_alsa.patch"
+pkgver() {
+ echo "$_latestver"
}
build() {
- cd "$srcdir/MSHV_$pkgver"
+ cd "$srcdir/MSHV_${_latestver}"
# There doesn't seem to be any difference between the .pro files apart from absolute paths
# passed to the linker for some libraries. We'll just rely on ld to find the libraries.
@@ -45,7 +57,7 @@ package() {
install -D -m755 mshv_launcher.sh "$pkgdir/usr/bin/mshv"
install -D -m644 mshv.desktop "$pkgdir/usr/share/applications/mshv.desktop"
- cd "$srcdir/MSHV_$pkgver/bin"
+ cd "$srcdir/MSHV_${_latestver}/bin"
install -D -m755 MSHV_x86_64 "$pkgdir/usr/bin/mshv_bin"
find . -type d -exec install -d -m755 "$pkgdir/usr/share/mshv/"{} \;
diff --git a/flrigxml.patch b/flrigxml.patch
deleted file mode 100644
index 2b866aef96a3..000000000000
--- a/flrigxml.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --color --unified --recursive --text package.old/src/HvRigControl/HvRigCat/network/network.cpp package.new/src/HvRigControl/HvRigCat/network/network.cpp
---- package.old/src/HvRigControl/HvRigCat/network/network.cpp 2021-07-27 10:15:16.000000000 +0200
-+++ package.new/src/HvRigControl/HvRigCat/network/network.cpp 2021-08-31 13:19:04.173424801 +0200
-@@ -471,7 +471,7 @@
- ts.append("Host: "+s_nethost+":"+s_netport+"\r\n");
- ts.append("Content-type: text/xml\r\n");
- char *hed1 = qstrdup(qPrintable(ts));
-- sprintf(xmlbuf,hed1);
-+ strcat(xmlbuf,hed1);
- /*sprintf(xmlbuf,
- "POST /RPC2 HTTP/1.1\r\n" "User-Agent: XMLRPC++ 0.8\r\n"
- "Host: 127.0.0.1:12345\r\n" "Content-type: text/xml\r\n");*/
diff --git a/pa_with_no_alsa.patch b/pa_with_no_alsa.patch
deleted file mode 100644
index edf1161f1669..000000000000
--- a/pa_with_no_alsa.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --color --unified --recursive --text package.old/src/SettingsMs/settings_ms.cpp package.new/src/SettingsMs/settings_ms.cpp
---- package.old/src/SettingsMs/settings_ms.cpp 2021-09-03 18:22:57.689795799 +0200
-+++ package.new/src/SettingsMs/settings_ms.cpp 2021-09-03 18:23:10.849795604 +0200
-@@ -529,7 +529,7 @@
- break;
- }
- }
-- if (!lst_f.isEmpty())
-+ if (true)
- {
-
- DevBoxAlsa->addItems(lst_f);