summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
-rw-r--r--disableWerror.patch124
3 files changed, 187 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd7975fb6382
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mstflint
+ pkgdesc = OpenFabrics Alliance firmware burning application for Mellanox HCA/NIC cards
+ pkgver = 4.0.1
+ pkgrel = 1
+ url = https://www.openfabrics.org/index.php/overview.html
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ license = custom:"Open Fabrics Alliance BSD"
+ depends = bash
+ depends = zlib
+ depends = libibmad
+ source = https://www.openfabrics.org/downloads/mstflint/mstflint-4.0.1-1.43.g97d7275.tar.gz
+ source = disableWerror.patch
+ md5sums = 7bcf30aa21f1951c6da918dbae25b23a
+ md5sums = 526da982d2827af23d00fe8f7306923b
+
+pkgname = mstflint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47df0496bc89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: James Harvey <jamespharvey20@gmail.com>
+# namcap says dependency 'libibmad' is not needed, but without it, configure fails with "cannot find infiniband/mad.h", provided by libibmad, and mstflint-4.0.1/mtcr_ul/mtcr_ib_ofed.c does include "infiniband/mad.h"
+
+pkgname=mstflint
+pkgver=4.0.1
+_pkgver_subver=1.43
+_pkgver_commit=g97d7275
+pkgrel=1
+pkgdesc='OpenFabrics Alliance firmware burning application for Mellanox HCA/NIC cards'
+arch=('x86_64' 'i686')
+url=('https://www.openfabrics.org/index.php/overview.html')
+license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
+depends=('bash' 'zlib' 'libibmad')
+source=("https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}-${_pkgver_subver}.${_pkgver_commit}.tar.gz"
+ 'disableWerror.patch')
+md5sums=('7bcf30aa21f1951c6da918dbae25b23a'
+ '526da982d2827af23d00fe8f7306923b')
+
+prepare() {
+ # v4.0.1.143.g97d7275 triggers -Werror, due to maybe uninitialized variables at fs3_ops.cpp:1727, 1863, and 1068
+ # Giving configure options of CFLAGS="-Wno-error" and CXXFLAGS="-Wno-error" doesn't work, because its build system adds "-Werror" at the end, which overrides
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Unsure how to use sed without updating timestamps, so using a patch
+ # Without --set-utc flag, aclocal rebuild is triggered, which is otherwise not a makedepends. Even if included, it is hardcoded to look for aclocal-1.13, and aclocal-1.15 would be installed
+ patch --set-utc -p1 -i ${srcdir}/disableWerror.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/disableWerror.patch b/disableWerror.patch
new file mode 100644
index 000000000000..b56e457a764f
--- /dev/null
+++ b/disableWerror.patch
@@ -0,0 +1,124 @@
+diff -rupN mstflint-4.0.1.original/cmdif/Makefile.am mstflint-4.0.1/cmdif/Makefile.am
+--- mstflint-4.0.1.original/cmdif/Makefile.am 2015-06-23 13:19:21.000000000 +0000
++++ mstflint-4.0.1/cmdif/Makefile.am 2015-06-23 13:19:21.000000000 +0000
+@@ -36,7 +36,7 @@ MTCR_DIR = $(USER_DIR)/include/mtcr_ul
+ TOOLS_LAYOUTS_DIR = $(USER_DIR)/tools_layouts
+ INCLUDES = -I. -I../common -I../tools_layouts -I$(MTCR_DIR) -I.. -I$(USER_DIR)/mtcr_ul
+
+-AM_CFLAGS = -W -Wall -Werror -g -MP -MD $(COMPILER_FPIC) -DCMDIF_EXPORTS
++AM_CFLAGS = -W -Wall -g -MP -MD $(COMPILER_FPIC) -DCMDIF_EXPORTS
+ CMDIF_VERSION = 1
+ noinst_LIBRARIES = libcmdif.a
+
+diff -rupN mstflint-4.0.1.original/cmdif/Makefile.in mstflint-4.0.1/cmdif/Makefile.in
+--- mstflint-4.0.1.original/cmdif/Makefile.in 2015-06-23 13:40:50.000000000 +0000
++++ mstflint-4.0.1/cmdif/Makefile.in 2015-06-23 13:40:50.000000000 +0000
+@@ -322,7 +322,7 @@ USER_DIR = $(top_srcdir)
+ MTCR_DIR = $(USER_DIR)/include/mtcr_ul
+ TOOLS_LAYOUTS_DIR = $(USER_DIR)/tools_layouts
+ INCLUDES = -I. -I../common -I../tools_layouts -I$(MTCR_DIR) -I.. -I$(USER_DIR)/mtcr_ul
+-AM_CFLAGS = -W -Wall -Werror -g -MP -MD $(COMPILER_FPIC) -DCMDIF_EXPORTS
++AM_CFLAGS = -W -Wall -g -MP -MD $(COMPILER_FPIC) -DCMDIF_EXPORTS
+ CMDIF_VERSION = 1
+ noinst_LIBRARIES = libcmdif.a
+ libcmdif_a_SOURCES = tools_cif.c
+diff -rupN mstflint-4.0.1.original/configure mstflint-4.0.1/configure
+--- mstflint-4.0.1.original/configure 2015-06-23 13:40:52.000000000 +0000
++++ mstflint-4.0.1/configure 2015-06-23 13:40:52.000000000 +0000
+@@ -15230,8 +15230,8 @@ if test "x$enable_dynamic_ld" = "xyes";
+
+ fi
+
+-CFLAGS="$CFLAGS -Werror -DMST_UL"
+-CXXFLAGS="$CXXFLAGS -Werror -DMST_UL"
++CFLAGS="$CFLAGS -DMST_UL"
++CXXFLAGS="$CXXFLAGS -DMST_UL"
+
+ ac_config_files="$ac_config_files mstflint.spec"
+
+diff -rupN mstflint-4.0.1.original/configure.ac mstflint-4.0.1/configure.ac
+--- mstflint-4.0.1.original/configure.ac 2015-06-23 13:19:21.000000000 +0000
++++ mstflint-4.0.1/configure.ac 2015-06-23 13:19:21.000000000 +0000
+@@ -61,8 +61,8 @@ AS_IF([test "x$enable_dynamic_ld" = "xye
+ LDFLAGS="$LDFLAGS -Wl,--dynamic-linker=/lib64/ld64.so.2"
+ ])
+
+-CFLAGS="$CFLAGS -Werror -DMST_UL"
+-CXXFLAGS="$CXXFLAGS -Werror -DMST_UL"
++CFLAGS="$CFLAGS -DMST_UL"
++CXXFLAGS="$CXXFLAGS -DMST_UL"
+
+ AC_CONFIG_FILES( mstflint.spec )
+
+diff -rupN mstflint-4.0.1.original/mft_utils/Makefile.am mstflint-4.0.1/mft_utils/Makefile.am
+--- mstflint-4.0.1.original/mft_utils/Makefile.am 2015-06-23 13:19:22.000000000 +0000
++++ mstflint-4.0.1/mft_utils/Makefile.am 2015-06-23 13:19:22.000000000 +0000
+@@ -34,7 +34,7 @@
+ USER_DIR = $(top_srcdir)
+ INCLUDES = -I. -I$(USER_DIR)/common
+
+-AM_CFLAGS = -MD -pipe -Wall -W -Werror
++AM_CFLAGS = -MD -pipe -Wall -W
+
+ noinst_HEADERS = mft_sig_handler.h errmsg.h
+
+diff -rupN mstflint-4.0.1.original/mft_utils/Makefile.in mstflint-4.0.1/mft_utils/Makefile.in
+--- mstflint-4.0.1.original/mft_utils/Makefile.in 2015-06-23 13:40:50.000000000 +0000
++++ mstflint-4.0.1/mft_utils/Makefile.in 2015-06-23 13:40:50.000000000 +0000
+@@ -341,7 +341,7 @@ top_srcdir = @top_srcdir@
+ # Makefile.am -- Process this file with automake to produce Makefile.in
+ USER_DIR = $(top_srcdir)
+ INCLUDES = -I. -I$(USER_DIR)/common
+-AM_CFLAGS = -MD -pipe -Wall -W -Werror
++AM_CFLAGS = -MD -pipe -Wall -W
+ noinst_HEADERS = mft_sig_handler.h errmsg.h
+ noinst_LIBRARIES = libmftutils.a
+ libmftutils_a_SOURCES = mft_sig_handler.c errmsg.cpp
+diff -rupN mstflint-4.0.1.original/reg_access/Makefile.am mstflint-4.0.1/reg_access/Makefile.am
+--- mstflint-4.0.1.original/reg_access/Makefile.am 2015-06-23 13:19:23.000000000 +0000
++++ mstflint-4.0.1/reg_access/Makefile.am 2015-06-23 13:19:23.000000000 +0000
+@@ -38,7 +38,7 @@ USER_DIR = $(top_srcdir)
+
+ INCLUDES = -I. -I$(USER_DIR) -I$(srcdir) -I$(LAYOUTS_DIR) -I$(USER_DIR)/include/mtcr_ul
+
+-AM_CFLAGS = -W -Wall -Werror -g -MP -MD $(COMPILER_FPIC)
++AM_CFLAGS = -W -Wall -g -MP -MD $(COMPILER_FPIC)
+
+ noinst_LIBRARIES = libreg_access.a
+
+diff -rupN mstflint-4.0.1.original/reg_access/Makefile.in mstflint-4.0.1/reg_access/Makefile.in
+--- mstflint-4.0.1.original/reg_access/Makefile.in 2015-06-23 13:40:51.000000000 +0000
++++ mstflint-4.0.1/reg_access/Makefile.in 2015-06-23 13:40:51.000000000 +0000
+@@ -323,7 +323,7 @@ COMMON_DIR = $(top_srcdir)/common
+ LAYOUTS_DIR = $(top_srcdir)/tools_layouts
+ USER_DIR = $(top_srcdir)
+ INCLUDES = -I. -I$(USER_DIR) -I$(srcdir) -I$(LAYOUTS_DIR) -I$(USER_DIR)/include/mtcr_ul
+-AM_CFLAGS = -W -Wall -Werror -g -MP -MD $(COMPILER_FPIC)
++AM_CFLAGS = -W -Wall -g -MP -MD $(COMPILER_FPIC)
+ noinst_LIBRARIES = libreg_access.a
+ libreg_access_a_SOURCES = reg_access.c
+ libreg_access_a_DEPENDENCIES = $(USER_DIR)/tools_layouts/libtools_layouts.a
+diff -rupN mstflint-4.0.1.original/tools_res_mgmt/Makefile.am mstflint-4.0.1/tools_res_mgmt/Makefile.am
+--- mstflint-4.0.1.original/tools_res_mgmt/Makefile.am 2015-06-23 13:19:23.000000000 +0000
++++ mstflint-4.0.1/tools_res_mgmt/Makefile.am 2015-06-23 13:19:23.000000000 +0000
+@@ -35,7 +35,7 @@ USER_DIR = $(top_srcdir)
+ MTCR_DIR = $(USER_DIR)/include/mtcr_ul
+ INCLUDES = -I. -I../common -I$(MTCR_DIR) -I.. -I$(USER_DIR)/mtcr_ul
+
+-AM_CFLAGS = -W -Wall -Werror -g -MP -MD $(COMPILER_FPIC)
++AM_CFLAGS = -W -Wall -g -MP -MD $(COMPILER_FPIC)
+ noinst_LIBRARIES = libtools_res_mgmt.a
+
+ libtools_res_mgmt_a_SOURCES = tools_res_mgmt.c
+diff -rupN mstflint-4.0.1.original/tools_res_mgmt/Makefile.in mstflint-4.0.1/tools_res_mgmt/Makefile.in
+--- mstflint-4.0.1.original/tools_res_mgmt/Makefile.in 2015-06-23 13:40:51.000000000 +0000
++++ mstflint-4.0.1/tools_res_mgmt/Makefile.in 2015-06-23 13:40:51.000000000 +0000
+@@ -321,7 +321,7 @@ top_srcdir = @top_srcdir@
+ USER_DIR = $(top_srcdir)
+ MTCR_DIR = $(USER_DIR)/include/mtcr_ul
+ INCLUDES = -I. -I../common -I$(MTCR_DIR) -I.. -I$(USER_DIR)/mtcr_ul
+-AM_CFLAGS = -W -Wall -Werror -g -MP -MD $(COMPILER_FPIC)
++AM_CFLAGS = -W -Wall -g -MP -MD $(COMPILER_FPIC)
+ noinst_LIBRARIES = libtools_res_mgmt.a
+ libtools_res_mgmt_a_SOURCES = tools_res_mgmt.c
+ all: all-am