summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--fcommon.patch13
3 files changed, 24 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dfbf60b4b61..deb1ad2b0067 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mtproxy-git
pkgdesc = Proxy server for Telegram messaging app
pkgver = 47.dc0c7f3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/TelegramMessenger/MTProxy
arch = i686
arch = x86_64
@@ -16,12 +16,14 @@ pkgbase = mtproxy-git
source = mtproxy-config.timer
source = mtproxy.service
source = pid_assertion.patch
+ source = fcommon.patch
md5sums = SKIP
md5sums = 1a9cdcef498d2e9ffb5def0112c3e2b0
md5sums = a67f6a3b3874d9dac15c7cf620d696c2
md5sums = aa2367c3f759632473824fabcc3544ff
md5sums = 1ee66acee6c42aca9160b9ccfe534bc3
md5sums = 50233354ac78d52280a93092b809f7aa
+ md5sums = 91501ebe32a2f3f9f6463703a1ca427f
pkgname = mtproxy-git
diff --git a/PKGBUILD b/PKGBUILD
index 3f393b41572c..e81554e08f3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@
pkgname=mtproxy-git
pkgver=47.dc0c7f3
-pkgrel=1
+pkgrel=2
pkgdesc="Proxy server for Telegram messaging app"
arch=('i686' 'x86_64')
url='https://github.com/TelegramMessenger/MTProxy'
@@ -31,6 +31,7 @@ source=(
mtproxy-config.timer
mtproxy.service
pid_assertion.patch
+ fcommon.patch
)
noextract=()
md5sums=('SKIP'
@@ -38,7 +39,8 @@ md5sums=('SKIP'
'a67f6a3b3874d9dac15c7cf620d696c2'
'aa2367c3f759632473824fabcc3544ff'
'1ee66acee6c42aca9160b9ccfe534bc3'
- '50233354ac78d52280a93092b809f7aa')
+ '50233354ac78d52280a93092b809f7aa'
+ '91501ebe32a2f3f9f6463703a1ca427f')
backup=('etc/mtproxy.conf')
pkgver() {
@@ -49,10 +51,14 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
patch --forward --strip=1 --input="$srcdir/pid_assertion.patch"
+ patch --forward --strip=1 --input="$srcdir/fcommon.patch"
}
build() {
cd "$srcdir/$pkgname"
+ export CFLAGS=-fcommon
+ export CXXFLAGS=-fcommon
+ export LDFLAGS=-fcommon
make $MFLAGS
}
diff --git a/fcommon.patch b/fcommon.patch
new file mode 100644
index 000000000000..d78ae6c83bbc
--- /dev/null
+++ b/fcommon.patch
@@ -0,0 +1,13 @@
+--- a/Makefile 2020-07-08 12:01:24.594082043 +0100
++++ b/Makefile 2020-07-08 12:01:42.124395380 +0100
+@@ -12,8 +12,8 @@
+ ARCH = -m64
+ endif
+
+-CFLAGS = $(ARCH) -O3 -std=gnu11 -Wall -mpclmul -march=core2 -mfpmath=sse -mssse3 -fno-strict-aliasing -fno-strict-overflow -fwrapv -DAES=1 -DCOMMIT=\"${COMMIT}\" -D_GNU_SOURCE=1 -D_FILE_OFFSET_BITS=64
+-LDFLAGS = $(ARCH) -ggdb -rdynamic -lm -lrt -lcrypto -lz -lpthread -lcrypto
++CFLAGS = $(ARCH) -fcommon -O3 -std=gnu11 -Wall -mpclmul -march=core2 -mfpmath=sse -mssse3 -fno-strict-aliasing -fno-strict-overflow -fwrapv -DAES=1 -DCOMMIT=\"${COMMIT}\" -D_GNU_SOURCE=1 -D_FILE_OFFSET_BITS=64
++LDFLAGS = $(ARCH) -fcommon -ggdb -rdynamic -lm -lrt -lcrypto -lz -lpthread -lcrypto
+
+ LIB = ${OBJ}/lib
+ CINCLUDE = -iquote common -iquote .