summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD8
-rw-r--r--RELEASENOTES.md49
3 files changed, 69 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 036dfe884a75..74df2f9056e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mulle-sde
pkgdesc = Cross-platform IDE for the command-line
- pkgver = 0.47.0
+ pkgver = 1.1.3
pkgrel = 1
epoch = 1
url = https://github.com/mulle-sde/mulle-sde
@@ -9,18 +9,21 @@ pkgbase = mulle-sde
groups = mulle-sde-all
license = BSD3
depends = bash
- depends = mulle-bashfunctions>=3.4.0
- depends = mulle-craft>=0.19.0
- depends = mulle-dispense>=2.0.2
- depends = mulle-env>=3.4.0
- depends = mulle-fetch>=2.0.0
- depends = mulle-make>=0.16.0
- depends = mulle-match>=0.8.0
- depends = mulle-monitor>=0.9.2
- depends = mulle-platform>=0.5.0
- depends = mulle-sourcetree>=0.25.0
- depends = mulle-template>=0.0.4
- source = https://github.com/mulle-sde/mulle-sde/archive/0.47.0.tar.gz
- md5sums = 4c3ef9c9526682a4dd301fca0e67cf3c
+ depends = mulle-bashfunctions>=4.1.1
+ depends = mulle-craft>=2.0.0
+ depends = mulle-dispense>=3.1.0
+ depends = mulle-domain>=1.0.1
+ depends = mulle-env>=4.1.0
+ depends = mulle-fetch>=3.0.1
+ depends = mulle-make>=1.1.1
+ depends = mulle-match>=1.0.1
+ depends = mulle-monitor>=1.0.1
+ depends = mulle-platform>=1.0.1
+ depends = mulle-semver>=1.0.1
+ depends = mulle-sourcetree>=1.1.0
+ depends = mulle-template>=1.0.1
+ depends = mulle-test>=6.1.0
+ source = https://github.com/mulle-sde/mulle-sde/archive/1.1.3.tar.gz
+ md5sums = d2db7693ee98fff1a6c28db3406a76b2
pkgname = mulle-sde
diff --git a/PKGBUILD b/PKGBUILD
index 299723f6ab75..2113085d3504 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jonathan Boyle <programmerfalcon@gmail.com>
pkgname=mulle-sde
-pkgver=0.47.0
+pkgver=1.1.3
pkgrel=1
epoch=1
pkgdesc="Cross-platform IDE for the command-line"
@@ -8,11 +8,11 @@ arch=('any')
url="https://github.com/mulle-sde/mulle-sde"
license=('BSD3')
groups=('mulle-sde-all')
-depends=('bash' 'mulle-bashfunctions>=3.4.0' 'mulle-craft>=0.19.0' 'mulle-dispense>=2.0.2' 'mulle-env>=3.4.0' 'mulle-fetch>=2.0.0' 'mulle-make>=0.16.0' 'mulle-match>=0.8.0' 'mulle-monitor>=0.9.2' 'mulle-platform>=0.5.0' 'mulle-sourcetree>=0.25.0' 'mulle-template>=0.0.4')
+depends=('bash' 'mulle-bashfunctions>=4.1.1' 'mulle-craft>=2.0.0' 'mulle-dispense>=3.1.0' 'mulle-domain>=1.0.1' 'mulle-env>=4.1.0' 'mulle-fetch>=3.0.1' 'mulle-make>=1.1.1' 'mulle-match>=1.0.1' 'mulle-monitor>=1.0.1' 'mulle-platform>=1.0.1' 'mulle-semver>=1.0.1' 'mulle-sourcetree>=1.1.0' 'mulle-template>=1.0.1' 'mulle-test>=6.1.0')
changelog="RELEASENOTES.md"
-source=("https://github.com/mulle-sde/mulle-sde/archive/0.47.0.tar.gz")
+source=("https://github.com/mulle-sde/mulle-sde/archive/1.1.3.tar.gz")
noextract=()
-md5sums=('4c3ef9c9526682a4dd301fca0e67cf3c')
+md5sums=('d2db7693ee98fff1a6c28db3406a76b2')
validpgpkeys=()
package() {
diff --git a/RELEASENOTES.md b/RELEASENOTES.md
index 9d8b446512b9..0a12b9bb1ff4 100644
--- a/RELEASENOTES.md
+++ b/RELEASENOTES.md
@@ -1,3 +1,50 @@
+### 1.1.3
+
+* fix craftinfo command
+
+### 1.1.2
+
+* fix duplicate display of current state
+
+### 1.1.1
+
+* fix config copy/remove command
+
+## 1.1.0
+
+* new command **env-identifier**
+* support for multiple sourcetrees with the improved **config** command
+* fixed --analyze option of the **craft** command
+* use style none/wild for project type none, instead of mulle/wild during the **init** command
+* new subcommand *variables* for the **project** command
+
+
+### 1.0.1
+
+* fix installer
+* big function rename to `<tool>`::`<file>`::`<function>` to make it easier to read hopefully
+* improve install command and especially the usage dox, to make it more transparent how to build static or dynamic product
+* introduce some shortcuts: dep for dependency, lib for library, ext for extension, pat for patternfile, sub for subprojects. Aliases are nice but mulle-sde dep is also nice...
+* the list command has changed to only list files by default
+* runs under zsh if bash is not installed
+* supports crafthelp in addition to craftinfo as well
+* uses mulle-bashfunctions 4 now
+* experimental **project remove** command
+* bequeath ``MULLE_SOURCETREE_USE_PLATFORM_MARKS_FOR_FETCH`` and ``MULLE_SOURCETREE_RESOLVE_TAG`` to newly iniited test projects
+
+# 1.0.0
+
+* big function rename to `<tool>`::`<file>`::`<function>` to make it easier to read hopefully
+* improve install command and especially the usage dox, to make it more transparent how to build static or dynamic product
+* introduce some shortcuts: dep for dependency, lib for library, ext for extension, pat for patternfile, sub for subprojects. Aliases are nice but mulle-sde dep is also nice...
+* the list command has changed to only list files by default
+* runs under zsh if bash is not installed
+* supports crafthelp in addition to craftinfo as well
+* uses mulle-bashfunctions 4 now
+* experimental **project remove** command
+* bequeath ``MULLE_SOURCETREE_USE_PLATFORM_MARKS_FOR_FETCH`` and ``MULLE_SOURCETREE_RESOLVE_TAG`` to newly iniited test projects
+
+
## 0.47.0
* add "test fetch" sub-command
@@ -128,7 +175,7 @@
### 0.38.4
-* remove accidental duplicate `sde_add_craftinfo_subproject_if_needed`
+* remove accidental duplicate `sde::craftinfo::add_craftinfo_subproject_if_needed`
### 0.38.3