summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD10
-rw-r--r--RELEASENOTES.md35
3 files changed, 46 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d619db01d84..3b6222e40c87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mulle-sourcetree
pkgdesc = Project composition and maintenance with build support
- pkgver = 0.23.1
- pkgrel = 2
+ pkgver = 1.2.0
+ pkgrel = 1
epoch = 1
url = https://github.com/mulle-sde/mulle-sourcetree
changelog = RELEASENOTES.md
@@ -9,9 +9,10 @@ pkgbase = mulle-sourcetree
groups = mulle-sde-all
license = BSD3
depends = bash
- depends = mulle-bashfunctions>=3.3.0
- source = https://github.com/mulle-sde/mulle-sourcetree/archive/0.23.1.tar.gz
- md5sums = b3d7027643c95b5abb7bcabd237637e6
+ depends = mulle-bashfunctions>=5.0.3
+ depends = mulle-env>=4.2.0
+ depends = mulle-fetch>=3.1.0
+ source = https://github.com/mulle-sde/mulle-sourcetree/archive/1.2.0.tar.gz
+ md5sums = cb4672034d020c70f8dea2279f740ccb
pkgname = mulle-sourcetree
-
diff --git a/PKGBUILD b/PKGBUILD
index 511044205e10..4572df9324b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Jonathan Boyle <programmerfalcon@gmail.com>
pkgname=mulle-sourcetree
-pkgver=0.23.1
-pkgrel=2
+pkgver=1.2.0
+pkgrel=1
epoch=1
pkgdesc="Project composition and maintenance with build support"
arch=('any')
url="https://github.com/mulle-sde/mulle-sourcetree"
license=('BSD3')
groups=('mulle-sde-all')
-depends=('bash' 'mulle-bashfunctions>=3.3.0')
+depends=('bash' 'mulle-bashfunctions>=5.0.3' 'mulle-env>=4.2.0' 'mulle-fetch>=3.1.0')
changelog="RELEASENOTES.md"
-source=("https://github.com/mulle-sde/mulle-sourcetree/archive/0.23.1.tar.gz")
+source=("https://github.com/mulle-sde/mulle-sourcetree/archive/1.2.0.tar.gz")
noextract=()
-md5sums=('b3d7027643c95b5abb7bcabd237637e6')
+md5sums=('cb4672034d020c70f8dea2279f740ccb')
validpgpkeys=()
package() {
diff --git a/RELEASENOTES.md b/RELEASENOTES.md
index 42f6c641459f..10ae5db0e857 100644
--- a/RELEASENOTES.md
+++ b/RELEASENOTES.md
@@ -1,3 +1,36 @@
+## 1.2.0
+
+* added --varbatim option to list and walk, so that error nodes show up and dont abort the listing
+
+
+## 1.1.0
+
+* added mulle-sourcetree-edit-csv and friends
+
+
+# 1.0.0
+
+* big function rename to `<tool>`::`<file>`::`<function>` to make it easier to read hopefully
+* list has now a -m option
+* experimental support for os-specific config files
+* implemented having a different config by uname, if so desired (needs reflect on each platform though)
+* cmake now used no-dynamic-link and no-static-link for `find_library`
+* fix wrong zombification, which means that mulle-sourcetree now doesn't refetch a lot of stuff gratuitously anymore *HUGE IMPROVEMENT*
+* removed parallel clean because of an as of yet undiagnosed problem with it
+* advertise tool in generated file
+* added a **diff** command
+* the status gained --shallow and --deep flags
+* the sync operation can perform some node syncs in parallel now (turn off with --serial)
+* needs mulle-bashfunctions 4.0.0 now
+* runs with zsh when installed, which can double the speed of sourcetree walk operations
+
+
+## 0.25.0
+
+* change/fix --no-bequeath --bequeath flags so it does what it promises to do and not the opposite
+* make column command optional
+
+
### 0.23.1
* fix indent for includes
@@ -117,7 +150,7 @@
* aliases need to include the name, so you can determine the lookup order
* buildorder is now using breadth-first for marks and in-order for filename to make things easier
* support various dedupe options
-* `node_printf` can print environment variables now with %v{ENVNAME,,}
+* `sourcetree::node::printf` can print environment variables now with %v{ENVNAME,,}
* many commands lose the unused filter options --marks --nodetypes and --permissions
* there is now a duplicate command for nodes
* node typeguess is a bit better now