summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
-rw-r--r--mullvad-vpn.install18
3 files changed, 36 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91f9a498d14a..d1fcfeeb3988 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = mullvad-vpn-beta-bin
pkgdesc = The Mullvad VPN client app for desktop (beta channel)
- pkgver = 2022.4.stable
+ pkgver = 2022.5.beta2
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
+ arch = aarch64
license = GPL3
depends = iputils
depends = libnotify
@@ -12,11 +13,15 @@ pkgbase = mullvad-vpn-beta-bin
depends = nss
provides = mullvad-vpn
conflicts = mullvad-vpn
- source = https://github.com/mullvad/mullvadvpn-app/releases/download/2022.4/MullvadVPN-2022.4_amd64.deb
- source = https://github.com/mullvad/mullvadvpn-app/releases/download/2022.4/MullvadVPN-2022.4_amd64.deb.asc
+ source = https://github.com/mullvad/mullvadvpn-app/releases/download/2022.5-beta2/MullvadVPN-2022.5-beta2_amd64.deb
+ source = https://github.com/mullvad/mullvadvpn-app/releases/download/2022.5-beta2/MullvadVPN-2022.5-beta2_amd64.deb.asc
+ source = https://github.com/mullvad/mullvadvpn-app/releases/download/2022.5-beta2/MullvadVPN-2022.5-beta2_arm64.deb
+ source = https://github.com/mullvad/mullvadvpn-app/releases/download/2022.5-beta2/MullvadVPN-2022.5-beta2_arm64.deb.asc
source = mullvad-vpn.sh
validpgpkeys = A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF
- sha256sums = 3b04ed5b39598c734548de7f5231496dcacf0aff7eb9c59810bda27588dea335
+ sha256sums = cb5abb13c5f21c98d120415732a291893d43ade9cb698c6c91cef1a2c2abc113
+ sha256sums = SKIP
+ sha256sums = b83efa6dbfb59d1bf3979e8011b8ad8a156c0aa1f27d30c175941bda5b5dbfac
sha256sums = SKIP
sha256sums = a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4
diff --git a/PKGBUILD b/PKGBUILD
index b7406eb89292..197a8d0ab23c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=mullvad-vpn-beta-bin
-_pkgver=2022.4
-_channel=stable
-_rel=1
+_pkgver=2022.5
+_channel=beta
+_rel=2
# beta
-#pkgver=${_pkgver}.${_channel}${_rel}
+pkgver=${_pkgver}.${_channel}${_rel}
# stable
-pkgver=${_pkgver}.${_channel}
+#pkgver=${_pkgver}.${_channel}
pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop (beta channel)"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://www.mullvad.net"
license=('GPL3')
depends=('iputils' 'libnotify' 'libappindicator-gtk3' 'nss')
@@ -17,26 +17,26 @@ provides=("${pkgname%-*-*}")
conflicts=("${pkgname%-*-*}")
install="${pkgname%-*-*}.install"
source=(
-# "https://github.com/mullvad/mullvadvpn-app/releases/download/${_pkgver}-${_channel}${_rel}/MullvadVPN-${_pkgver}-${_channel}${_rel}_amd64.deb"{,.asc} # beta
- "https://github.com/mullvad/mullvadvpn-app/releases/download/${_pkgver}/MullvadVPN-${_pkgver}_amd64.deb"{,.asc} # stable
+ "https://github.com/mullvad/mullvadvpn-app/releases/download/${_pkgver}-${_channel}${_rel}/MullvadVPN-${_pkgver}-${_channel}${_rel}_amd64.deb"{,.asc} # beta
+ "https://github.com/mullvad/mullvadvpn-app/releases/download/${_pkgver}-${_channel}${_rel}/MullvadVPN-${_pkgver}-${_channel}${_rel}_arm64.deb"{,.asc} # beta
+# "https://github.com/mullvad/mullvadvpn-app/releases/download/${_pkgver}/MullvadVPN-${_pkgver}_amd64.deb"{,.asc} # stable
+# "https://github.com/mullvad/mullvadvpn-app/releases/download/${_pkgver}/MullvadVPN-${_pkgver}_arm64.deb"{,.asc} # stable
"${pkgname%-*-*}.sh"
)
-sha256sums=('3b04ed5b39598c734548de7f5231496dcacf0aff7eb9c59810bda27588dea335'
+sha256sums=('cb5abb13c5f21c98d120415732a291893d43ade9cb698c6c91cef1a2c2abc113'
+ 'SKIP'
+ 'b83efa6dbfb59d1bf3979e8011b8ad8a156c0aa1f27d30c175941bda5b5dbfac'
'SKIP'
'a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4')
validpgpkeys=('A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF') # Mullvad (code signing) <admin@mullvad.net>
package() {
bsdtar -xvf data.tar.xz -C "$pkgdir/"
+ chmod 4755 "$pkgdir/opt/Mullvad VPN/chrome-sandbox"
# Link to the GUI binary
install -m755 "$srcdir/${pkgname%-*-*}.sh" "$pkgdir/usr/bin/${pkgname%-*-*}"
- # Symlink daemon service to correct directory
- install -d "$pkgdir/usr/lib/systemd/system"
- ln -s "/opt/Mullvad VPN/resources/mullvad-daemon.service" \
- "$pkgdir/usr/lib/systemd/system/"
-
# Move ZSH completions to correct directory
mv "$pkgdir/usr/local/share/zsh" "$pkgdir/usr/share/"
rm -rf "$pkgdir/usr/local"
diff --git a/mullvad-vpn.install b/mullvad-vpn.install
index a03c95fc1574..0b29ddc28ea2 100644
--- a/mullvad-vpn.install
+++ b/mullvad-vpn.install
@@ -3,6 +3,8 @@ pre_install() {
echo 'Stopping & disabling Mullvad VPN daemon...'
/opt/Mullvad\ VPN/resources/mullvad-setup prepare-restart || true
systemctl disable --now mullvad-daemon
+ echo 'Disabling Mullvad early boot blocking service...'
+ systemctl disable mullvad-early-boot-blocking.service || true
cp /var/log/mullvad-vpn/daemon.log /var/log/mullvad-vpn/old-install-daemon.log \
|| echo "Failed to copy old daemon log"
fi
@@ -18,6 +20,7 @@ post_install() {
echo 'Enabling Mullvad VPN daemon...'
systemctl enable --now mullvad-daemon
+ systemctl enable mullvad-early-boot-blocking
}
pre_upgrade() {
@@ -28,17 +31,22 @@ post_upgrade() {
echo 'Starting & enabling Mullvad VPN daemon...'
systemctl daemon-reload
systemctl enable --now mullvad-daemon
+ echo 'Enabling Mullvad early boot blocking service...'
+ systemctl enable mullvad-early-boot-blocking
chmod u+s "/usr/bin/mullvad-exclude"
}
pre_remove() {
- # the user might've disabled or stopped the service themselves already
- echo 'Making sure the Mullvad VPN daemon is stopped & disabled...'
- systemctl stop mullvad-daemon || true
- systemctl disable mullvad-daemon || true
+ # SIGTERM for some reason causes the app to crash sometimes and SIGINT works as expected.
+ pkill -2 -x "mullvad-gui" || true
+ sleep 0.5
+ pkill -9 -x "mullvad-gui" || true
- pkill -x "mullvad-gui" || true
+ # the user might've disabled or stopped the services themselves already
+ echo 'Making sure the services are stopped & disabled...'
+ systemctl disable --now mullvad-daemon || true
+ systemctl disable --now mullvad-early-boot-blocking.service || true
/opt/Mullvad\ VPN/resources/mullvad-setup reset-firewall || echo "Failed to reset firewall"
/opt/Mullvad\ VPN/resources/mullvad-setup remove-device || echo "Failed to remove device from account"