summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--mullvad-vpn.install10
3 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7f4b5784bb2..79376f187bac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mullvad-vpn-beta-bin
pkgdesc = The Mullvad VPN client app for desktop (latest/beta release)
- pkgver = 2020.5.stable
+ pkgver = 2020.6.beta3
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
@@ -12,11 +12,11 @@ pkgbase = mullvad-vpn-beta-bin
depends = nss
provides = mullvad-vpn
conflicts = mullvad-vpn
- source = https://github.com/mullvad/mullvadvpn-app/releases/download/2020.5/MullvadVPN-2020.5_amd64.deb
- source = https://github.com/mullvad/mullvadvpn-app/releases/download/2020.5/MullvadVPN-2020.5_amd64.deb.asc
+ source = https://github.com/mullvad/mullvadvpn-app/releases/download/2020.6-beta3/MullvadVPN-2020.6-beta3_amd64.deb
+ source = https://github.com/mullvad/mullvadvpn-app/releases/download/2020.6-beta3/MullvadVPN-2020.6-beta3_amd64.deb.asc
source = mullvad-vpn.sh
validpgpkeys = A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF
- sha256sums = 760b1482e20d4064e3da20575950783d7ce10e092e386154b1ac737929363f8c
+ sha256sums = 4097fbee72bb5984484b0e6e08e1565bdcc794bebe1f8a1b7e41c3d3d620769c
sha256sums = SKIP
sha256sums = a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4
diff --git a/PKGBUILD b/PKGBUILD
index 59958bdbdce6..79c094f897a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=mullvad-vpn-beta-bin
-_pkgver=2020.5
-_channel=stable
-pkgver=${_pkgver}.${_channel}
+_pkgver=2020.6
+_channel=beta
+pkgver=${_pkgver}.${_channel}3
pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop (latest/beta release)"
url="https://www.mullvad.net"
@@ -12,9 +12,9 @@ depends=('libnotify' 'libappindicator-gtk3' 'libxss' 'nss')
provides=("${pkgname%-beta-bin}")
conflicts=("${pkgname%-beta-bin}")
install="${pkgname%-beta-bin}.install"
-source=("https://github.com/mullvad/mullvadvpn-app/releases/download/$_pkgver/MullvadVPN-${_pkgver}_amd64.deb"{,.asc}
+source=("https://github.com/mullvad/mullvadvpn-app/releases/download/${_pkgver}-${_channel}3/MullvadVPN-${_pkgver}-${_channel}3_amd64.deb"{,.asc}
"${pkgname%-beta-bin}.sh")
-sha256sums=('760b1482e20d4064e3da20575950783d7ce10e092e386154b1ac737929363f8c'
+sha256sums=('4097fbee72bb5984484b0e6e08e1565bdcc794bebe1f8a1b7e41c3d3d620769c'
'SKIP'
'a59c29f07b4eab9af56f0e8be42bae0d83726f5185e88de0c5a48f4098c3c0a4')
validpgpkeys=('A1198702FC3E0A09A9AE5B75D5A1D4F266DE8DDF') # Mullvad (code signing) <admin at mullvad dot net>
diff --git a/mullvad-vpn.install b/mullvad-vpn.install
index 95ec59694b77..b348092ea0fc 100644
--- a/mullvad-vpn.install
+++ b/mullvad-vpn.install
@@ -5,14 +5,16 @@ pre_install() {
systemctl disable --now mullvad-daemon
fi
+ pkill -x "mullvad-gui" || true
+
rm -f /var/cache/mullvad-vpn/relays.json || true
}
post_install() {
+ chmod u+s "/usr/bin/mullvad-exclude"
+
echo 'Enabling Mullvad VPN daemon...'
systemctl enable --now mullvad-daemon
-
- chmod u+s "/usr/bin/mullvad-exclude"
}
pre_upgrade() {
@@ -28,10 +30,14 @@ post_upgrade() {
}
pre_remove() {
+ /usr/bin/mullvad account clear-history || echo "Failed to remove leftover WireGuard keys"
+
# the user might've disabled or stopped the service themselves already
echo 'Making sure the Mullvad VPN daemon is stopped & disabled...'
systemctl stop mullvad-daemon || true
systemctl disable mullvad-daemon || true
+
+ /opt/Mullvad\ VPN/resources/mullvad-setup reset-firewall || true
}
post_remove() {