summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05a4140a54cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = multiload-ng-common-git
+ pkgdesc = Modern graphical system monitor, common files
+ pkgver = r938.d023877
+ pkgrel = 3
+ url = https://udda.github.io/multiload-ng/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = intltool
+ makedepends = git
+ conflicts = multiload-ng-common
+ source = git+https://github.com/udda/multiload-ng.git
+ md5sums = SKIP
+
+pkgname = multiload-ng-common-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e02870c66b57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Michael Kogan <michael.kogan at gmx dot net>
+# Co-maintainer: Mario Cianciolo <mr.udda at gmail dot com>
+
+# This file is automatically generated from multiload-ng source.
+
+pkgname='multiload-ng-common-git'
+pkgdesc='Modern graphical system monitor, common files'
+pkgver=r938.d023877
+pkgrel=3
+
+makedepends=('intltool' 'git')
+depends=()
+
+conflicts=('multiload-ng-common')
+
+source=("git+https://github.com/udda/multiload-ng.git")
+md5sums=('SKIP')
+
+arch=('i686' 'x86_64')
+url='https://udda.github.io/multiload-ng/'
+license=('GPL2')
+
+build() {
+ cd "multiload-ng"
+ ./autogen.sh
+ ./configure --prefix=/usr --with-gtk=2.0 --without-awn --without-indicator --without-lxpanel --without-mate --without-standalone --without-systray --without-xfce4
+ make
+}
+
+package() {
+ cd "multiload-ng"
+ make DESTDIR="$pkgdir" install
+}
+
+pkgver() {
+ cd "multiload-ng"
+ printf -- "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}