summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--build-fix.patch24
3 files changed, 30 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9478c0038dc1..8a1e1dc17356 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,9 @@ pkgbase = multiload-ng-standalone-gtk3
conflicts = multiload-ng-standalone-gtk2-git
conflicts = multiload-ng-standalone-gtk3-git
source = https://github.com/udda/multiload-ng/archive/v1.5.2.tar.gz
+ source = build-fix.patch
md5sums = bdb9344d696324bd4db04a8bce6d7ec0
+ md5sums = b474387e4532bdd6a639f721a51d2587
pkgname = multiload-ng-standalone-gtk3
diff --git a/PKGBUILD b/PKGBUILD
index cc0a2aaa669d..10bc1e5e5b11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,9 @@ depends=('gtk3' 'cairo' 'multiload-ng-common')
conflicts=('multiload-ng-standalone-gtk2' 'multiload-ng-standalone-gtk2-git' 'multiload-ng-standalone-gtk3-git')
-source=("https://github.com/udda/multiload-ng/archive/v$pkgver.tar.gz")
-md5sums=('bdb9344d696324bd4db04a8bce6d7ec0')
+source=("https://github.com/udda/multiload-ng/archive/v$pkgver.tar.gz" "build-fix.patch")
+md5sums=('bdb9344d696324bd4db04a8bce6d7ec0'
+'b474387e4532bdd6a639f721a51d2587')
arch=('i686' 'x86_64')
url='https://udda.github.io/multiload-ng/'
@@ -22,6 +23,7 @@ license=('GPL2')
build() {
cd "multiload-ng-$pkgver"
+ patch -p1 -i $srcdir/build-fix.patch
./autogen.sh
./configure --prefix=/usr --with-gtk=3.0 --disable-deprecations --without-awn --without-indicator --without-lxpanel --without-mate --with-standalone --without-systray --without-xfce4
make
diff --git a/build-fix.patch b/build-fix.patch
new file mode 100644
index 000000000000..6e7f125bad49
--- /dev/null
+++ b/build-fix.patch
@@ -0,0 +1,24 @@
+diff -Naur a/common/multiload-config.c b/common/multiload-config.c
+--- a/common/multiload-config.c 2016-12-05 17:13:59.000000000 +0100
++++ b/common/multiload-config.c 2020-07-30 21:18:03.568945194 +0200
+@@ -26,6 +26,8 @@
+ #include "graph-data.h"
+ #include "multiload-config.h"
+
++GraphType graph_types[GRAPH_MAX];
++
+ guint multiload_config_get_num_colors(guint id)
+ {
+ g_assert_cmpuint (graph_types[id].num_colors, <=, MAX_COLORS);
+diff -Naur a/common/multiload-config.h b/common/multiload-config.h
+--- a/common/multiload-config.h 2016-12-05 17:13:59.000000000 +0100
++++ b/common/multiload-config.h 2020-07-30 21:18:21.685273529 +0200
+@@ -56,7 +56,7 @@
+
+
+ // global variable
+-GraphType graph_types[GRAPH_MAX];
++extern GraphType graph_types[GRAPH_MAX];
+
+
+ G_GNUC_INTERNAL guint