summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
2 files changed, 28 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cfab3cdc8e3..8c7e8fac940b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = multipass
pkgdesc = Broadcast X11 key events to multiple windows
- pkgver = 17.09
- pkgrel = 3
- url = https://github.com/vain/multipass
+ pkgver = 18.06
+ pkgrel = 1
+ url = https://www.uninformativ.de/git/multipass
arch = any
license = MIT
makedepends = git
depends = libx11
depends = libxft
- source = https://github.com/vain/multipass/archive/v17.09.tar.gz
- source = https://raw.githubusercontent.com/vain/multipass/master/LICENSE
- sha256sums = 001f760bde3392e9289f03987c2a5dbc61e8adcc4b575cfad96da88b28ba18fe
- sha256sums = SKIP
+ source = git+https://www.uninformativ.de/git/multipass.git
+ md5sums = SKIP
pkgname = multipass
diff --git a/PKGBUILD b/PKGBUILD
index 2a71fbf1215b..0c0fea918d3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,35 @@
# Maintainer: yhaupenthal <y dot h plus aur at posteo dot de>
pkgname=multipass
-pkgver='17.09'
-pkgrel=3
+pkgver='18.06'
+pkgrel=1
pkgdesc='Broadcast X11 key events to multiple windows'
arch=('any')
-url='https://github.com/vain/multipass'
+url='https://www.uninformativ.de/git/multipass'
license=('MIT')
depends=('libx11' 'libxft')
makedepends=('git')
-source=("https://github.com/vain/${pkgname}/archive/v${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/vain/${pkgname}/master/LICENSE")
-sha256sums=('001f760bde3392e9289f03987c2a5dbc61e8adcc4b575cfad96da88b28ba18fe'
- 'SKIP')
+source=('git+https://www.uninformativ.de/git/multipass.git')
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+
+ # custom config
+ echo "$SRCDEST"
+ if [ -e "$SRCDEST"/config.h ] ; then
+ echo 'Using custom config.h'
+ cp "$SRCDEST"/config.h .
+ else
+ cp config.def.h config.h
+ fi
+}
+
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "$srcdir/$pkgname"
make
}
+
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- install -D -m 644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m 755 "${srcdir}/${pkgname}-${pkgver}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ cd "$srcdir/$pkgname"
+ install -Dm 755 "$srcdir/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
}