summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rwxr-xr-xMakefile.inc2
-rwxr-xr-xPKGBUILD11
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0a5c9477c0c..a4e61b5aa630 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by makepkg 5.0.0
-# Tue Feb 16 17:33:54 UTC 2016
pkgbase = mumps
pkgdesc = Sparse solver library using Gaussian elimination
pkgver = 5.0.1
- pkgrel = 1
+ pkgrel = 2
url = http://mumps.enseeiht.fr
arch = i686
arch = x86_64
@@ -13,11 +11,12 @@ pkgbase = mumps
depends = scotch>=6.0.3-3
depends = scalapack
depends = metis
+ depends = zlib
depends = bzip2
source = http://mumps.enseeiht.fr/MUMPS_5.0.1.tar.gz
source = Makefile.inc
md5sums = b477573fdcc87babe861f62316833db0
- md5sums = e1d80cc7b2f942f1451e764a6c0e8567
+ md5sums = 6dff109173476993b430856aad890a45
pkgname = mumps
diff --git a/Makefile.inc b/Makefile.inc
index cb51e35ff890..25ad331ab64c 100755
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -23,7 +23,7 @@ ISCOTCH = -I$(SCOTCHDIR)/include/scotch
# variable below); for both parallel and sequential analysis choose the second
# line (remember to add -Dptscotch in the ORDERINGSF variable below)
-LSCOTCH = -L$(SCOTCHDIR)/lib -lesmumps -lbz2 -lscotch -lscotcherr
+LSCOTCH = -L$(SCOTCHDIR)/lib -lesmumps -lbz2 -lz -lscotch -lscotcherr
#LSCOTCH = -L$(SCOTCHDIR)/lib -lptesmumps -lptscotch -lptscotcherr -lscotchmetis
#LSCOTCH = -L$(SCOTCHDIR)/lib -lptesmumps -lptscotch -lptscotcherr -lscotchmetis -lscotch
diff --git a/PKGBUILD b/PKGBUILD
index f98293b701ef..a03c4107b719 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,21 @@
# Contributor: Lucas H. Gabrielli
pkgname=mumps
pkgver=5.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Sparse solver library using Gaussian elimination"
url="http://mumps.enseeiht.fr"
license=("custom")
-depends=('lapack' 'openmpi' 'scotch>=6.0.3-3' 'scalapack' 'metis' 'bzip2')
+depends=('lapack' 'openmpi' 'scotch>=6.0.3-3' 'scalapack' 'metis' 'zlib' 'bzip2')
makedepends=()
provides=()
conflicts=()
replaces=()
backup=()
arch=('i686' 'x86_64')
-source=(http://mumps.enseeiht.fr/MUMPS_${pkgver}.tar.gz Makefile.inc)
+source=(http://mumps.enseeiht.fr/MUMPS_${pkgver}.tar.gz
+ Makefile.inc)
+md5sums=('b477573fdcc87babe861f62316833db0'
+ '6dff109173476993b430856aad890a45')
build() {
cd "${srcdir}/MUMPS_${pkgver}"
@@ -64,5 +67,3 @@ package(){
# Install license
install -D -m644 "${srcdir}/MUMPS_${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-md5sums=('b477573fdcc87babe861f62316833db0'
- 'e1d80cc7b2f942f1451e764a6c0e8567')